Citibank : VAN page doesn't allow data entry or is unavailable

RESOLVED FIXED in Camino1.0

Status

Camino Graveyard
HTML Form Controls
--
critical
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Jason Trindade, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({qawanted, regression})

unspecified
Camino1.0
PowerPC
Mac OS X
qawanted, regression

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040804 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040804 Camino/0.8+

With a citibank account one can launch the citibank virtual account numbers
(VAN) webpage which asks for a login and password. In previous versions of
camino this worked fine (there are no navigation buttons as this is a popup).
When I try to type in my password or account name I get typeahead find tries. If
I manage to stop typeahead find it starts again. This may be something strange
in my setup that I forgot was done, but I seem to recall this working w/
typeahead enabled. I also cannot paste my username into the username field even
when the insertion point is blinking and that field is actively clicked as
'copy' is the only thing available in the edit menu.

Reproducible: Always
Steps to Reproduce:
1. Log into a citibank account
2. Launch the Virtual Account Numbers web panel
3. Attempt to type or paste in data

Actual Results:  
No paste available and typeahead find tries to enter on keystrokes by default,
if stopped entry is still unavailable.

Expected Results:  
I should have been able to type in my login and password as usual.

Cannot provide URL currently as it may be linked to my initial login to my
citibank accounts, but will try to find another link on the site which is no
personal. Will provide if report is not a duplicate or an error on my part and
the subsequent report can be kept in line with the security policy.
Jason does FireFox or Mozilla the suite work with citybank ?
Keywords: qawanted, regression
(Reporter)

Comment 2

14 years ago
Doesn't happen in Firefox (current, not daily build).
(Reporter)

Comment 3

14 years ago
also works correctly with mozilla current release.  It is a pop-up, but I have
blocking off. It seems like it's the type-ahead find issue so is there a way to
turn it off and test it?
thanks
(Reporter)

Comment 4

13 years ago
I checked today w/ nightly 2004081408 (v0.8+) and this is still occurring. There
doesn't seem to be any way to access the  VAN popup without logging into a
citibank credit card information right now so I can't really provide a url. I
definitely blocks typing by firing up typeahead find in the popup instead of
entry, but I'm still wondering if it's something I may have changed in my
profile as it works w/ firefox and mozilla. Ideas anyone?
Thanks.
-Jason Trindade
(Reporter)

Comment 5

13 years ago
No closer bugs seem to exist. Changed title to make searching easier for other
people. The closest bug seems to be
http://bugzilla.mozilla.org/show_bug.cgi?id=85557 which doesn't seem to say
much, but may be indicative of when this problem started to occur (other bugs
close to this are p1 but I can't change it). 

This bug appears to be worse than I stated as per Trevor's comments in Camino
Digest, Vol 14, Issue 11. Apparently some people can't even get to the terms and
conditions or launch page.  So now there may be two bugs (keep here or file
second?) Still no WFM but if we add access to this I'd say the digest comments
make this confirmed regression.

Thanks-Jason
Summary: Instead of allowing data entry via keypresses or paste, keypresses only do typeahead and no paste available → Citibank : VAN page doesn't allow data entry or is unavailable

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

13 years ago
Still happening in 2004103008 (v0.8+) 
(Reporter)

Comment 7

13 years ago
Here is the source:
<html>
<head>
<META http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title>Virtual Account Numbers</title>
<meta content="text/html; charset=iso-8859-1" http-equiv="Content-Type">
<style type="text/css">
<!--
.Card     {  position: absolute; visibility: visible; left: 0px;  top: 0px}
.Comms    {  position: absolute; visibility: hidden; left: 0px;  top: 0px;}
-->
</style>
<script src="https://www.accountonline.com/VAN/webcard/disable.js"
language="JavaScript"></script>
</head>
<body onload="focusMovie()" marginheight="0" marginwidth="0" topmargin="0"
leftmargin="0" bgcolor="#003499">
<SCRIPT SRC="https://www.accountonline.com/VAN/webcard/webcard.js"
LANGUAGE="Javascript"></SCRIPT><SCRIPT LANGUAGE="VBScript">
Sub webcard_FSCommand(ByVal command, ByVal args)
	call webcard_DoFSCommand(command, args)
End Sub
</SCRIPT><SCRIPT LANGUAGE="Javascript">
var defaultVars, ieVars, nsVars, thinclient;

thinclient = true;
defaultVars =
"langcode=en&base=https://www.accountonline.com/VAN/webcard/&GeneralError=General+Error&loginAssetLib=loginlib.swf"
defaultVars += "&loadProfiles=true&cfg=config.txt&Issuer=1&brand=Citi";

ieVars = defaultVars + "&Browser=IE";
nsVars = defaultVars + "&Browser=NS";



writeFlashObject("https://www.accountonline.com/VAN/webcard/CitiUS3.swf",
"webcard", ieVars, nsVars, 730, 250, "6,0,40,0", false);
init();
focusMovie();
</SCRIPT>
</body>

</html>

Comment 8

13 years ago
reporter - please confirm that this is still a problem. we fixed a bug about
typing into flash a while ago...
Severity: blocker → critical
Target Milestone: --- → Camino1.0
(Reporter)

Comment 9

13 years ago
Thank you, with NB 2005030808 (v0.8+) this problem has been fixed. I know this
was on the mailing list. Good bugfix! Resolved WFM.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.