Closing View Source window for iframe closes Firefox instantly

RESOLVED WORKSFORME

Status

()

Toolkit
View Source
--
critical
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Joel Risberg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Closing a View Source window containing the source of an iframe causes an
instant close of all Firefox windows and tabs. This may be a crash, but there's
no error so it's possible it's simply closing the entire app and bypassing the
standard multiple tab warnings. A View Source for a non-iframe frame doesn't
exhibit the problem.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.james-taylor.com/
2. Right-click on the 468x60 banner ad at the top of the window
3. Select "This Frame" / "View Frame Source"
4. Use the standard windows "close window" button to close the View Source window.
5. All Firefox windows close.

Actual Results:  
In addition to the View Source window, the main Firefox window and all open tabs
are closed instantly with no confirmation.

Expected Results:  
Only the View Source window should close, leaving the Firefox main window and
tabs open.

It may be a crash, but there were no errors.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040807
Firefox/0.9.1+

WFM

Comment 2

14 years ago
Joel: Did TalkBack Quality Feedback Agent appear? If yes, could you provide
TalkBack incident ID?
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> Joel: Did TalkBack Quality Feedback Agent appear? If yes, could you provide
> TalkBack incident ID?

I've just re-confirmed -- The agent does not appear. The behavior is exactly
like closing the entire app, only there is no confirmation for multiple tabs
left open. While the View Source window opens maximized (at least for me),
behavior is the same whether the View Source window is maximized or not.
(Reporter)

Comment 4

13 years ago
This bug still exists in Firefox 1.0 final release.
(Reporter)

Comment 5

13 years ago
Some additional information: This bug occurs most consistently with iframes for
"Ads By Google," a very popular ad network. Since ads on the james-taylor.com
site described above are provided by various sources, you may need to reload
several times before you get a google iframe ad.  In my testing the bug occurs
every time with these types of ads, but only sporadically with other iframe code.

Comment 6

13 years ago
reporter: check components for a talkback.exe, it probably is not present, after
you've verified it's missing, run the installer again, select manual and check
talkback.
(Reporter)

Comment 7

13 years ago
Talkback is enabled and has no effect. I also ran the talkback.exe component
manually, ran Firefox and reproduced the bug, but there was still no talkback
activation. Talkback doesn't seem to recognize the bug as a crash and no report
is generated.

Comment 8

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050322
Firefox/1.0+

Testing in latest nightly with a clean profile.  No crash/closing/anything. 
Behaves as expected.  Tried it on several different iframed ads on that site,
including an "Ads By Google" ad, as suggested by the reporter in comment #5

Marking this Resolved WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.