Text-decoration:underline doesn't change color like the text when hovering over it

VERIFIED DUPLICATE of bug 241627

Status

()

Core
Layout: Text
--
trivial
VERIFIED DUPLICATE of bug 241627
14 years ago
12 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040808 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040808 Firefox/0.9.1+

See upcoming testcase.
Basically, the problem is that the bottom line of the text should also change
it's color to green when hovering over the text. 

this was the minimal testcase I could come up with:
<html><head>
<style type="text/css">
div{
color:red;
text-decoration:underline overline;
font-size: 12px;
font-family: -moz-fixed;
}
div:hover{color:green;}
</style>
</head>

<body>
<h2>dummy text to trigger bug</h2>
<div>Mouseover this, the underline should become green also, but it doesn't</div>
</body></html>

So it happens only in very specific cases.

Reproducible: Always
Steps to Reproduce:
1. See testcase
2. Hover over text
3.

Actual Results:  
The underline didn't turn green, but stayed red.

Expected Results:  
Also the underline should turn green.
(Reporter)

Comment 1

14 years ago
Created attachment 155497 [details]
Testcase

Comment 2

14 years ago
maybe related: Bug 241627, Bug 35146
(Reporter)

Comment 3

14 years ago
Ah, this is most likely a duplicate of bug 241627, since the testcase came
originally from a site which used pre tags.

*** This bug has been marked as a duplicate of 241627 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 4

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b) Gecko/20050205
Firefox/1.0+

WFM

Comment 5

12 years ago
I can repro this bug with yesterday's trunk build but not with today's, so verifying that it's a dup.  (Testing on WinXP.)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.