intrade.com never finishes loading and sometimes crashes [@ 0x00000000 - gklayout.dll ]

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: Dvir, Unassigned)

Tracking

({crash, hang})

Trunk
x86
Windows 2000
crash, hang

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.1) Gecko/20040707

Every time I try to connect to the intrade url, the loading stops in the middle.
After I close the tab, the browser doesn't load any other web site and needs to
be restarted. Sometimes closing the tab crashes the browser.
I sent talkback #TB510894Z for this behavior.

Reproducible: Always
Steps to Reproduce:
1. load http://www.intrade.com in a new tab
2. wait a minute - the page doesn't come up
3. close the tab

Actual Results:  
Either the browser crashed or became unusable.


Talkback TB510894Z

Comment 1

14 years ago
TB510894Z shows:
0x00000000
gklayout.dll + 0x22f6e (0x61402f6e)
gklayout.dll + 0x1cf50 (0x613fcf50)
[...]
Severity: normal → critical
Keywords: crash
Summary: intrade.com never finishes loading and sometimes crashes mozilla suite → intrade.com never finishes loading and sometimes crashes [@ 0x00000000 - gklayout.dll ]

Comment 2

14 years ago
confirming
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040807
Java Plug-in 1.5.0 for Netscape Navigator (DLL Helper)    (1.5.0beta2)

crash at first load, and first load with a fresh profile.
page loads normally, then Java starts, an applet is loaded, when loading
finishes, and the applet has updated the trading table, crash
Restarting browser, the applet loads. Clicking on one of the entries, another
window is opened (or the same, don´t remember) loading a big applet.
Tab is spinning, applet is rotating, progressbar of applet empty and not
updating. closing that window, I returned to the browser, closing the browser,
crash.
at other tries the second applet didn´t load, instead a broken applet symbol was
shown, javaconsole told a lot of exceptions, last related to netscape.js.
talkback was registered in windows registry, but didn´t come up.
I also got the impression, maybe the crashes happened because I´m low on memory,
only 96 MB in this box.
Also browser started offline, or maybe switched to offline somewhere on this site.

OJI?

Comment 3

14 years ago
After submitting, I tried once more, crashed once more.
DocWatson is comming up, Talkback not, though registered in Windows registry.

Message from DocWatson, my translation from german to English:
(unknown) tried to access non-existant memory, Module: (unknown)
stack summary:
hex, JPINSCP.DLL, hex, hex, hex, hex, JVM.DLL, JVM.DLL, JVM.DLL, JVM.DLL,
JAVA.DLL, hex, hex, hex, hex, JVM.DLL, JVM.DLL, JVM.DLL, JVM.DLL, JVM.DLL,
JVM.DLL, JVM.DLL, MSVCRT.DLL, Kernel32!ThreadStartup


Comment 4

14 years ago
success in getting a useless Talkback, TB513531M, as DocWatson shows crash in
MSVCRT.DLL

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB513531M

MSVCRT.DLL + 0xd2fb (0x7800d2fb)
MSVCRT.DLL + 0xcc3f (0x7800cc3f)
??3@YAXPAX@Z
XPCWrappedNative::`scalar deleting destructor'
XPCWrappedNative::Release 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 845]
XPCWrappedNative::FlatJSObjectFinalized 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 909]
js_FinalizeObject 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsobj.c, line
2088]
0x028a3550
0x02a5b830

as seen in a lot of crashes showing different messages, I assume it is Java, but
don´t know, if it is Java APIs for DOM, XPCOM, LiveConnect or OJI, or all of these.
next try after submitting

Comment 6

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040805
javaconsole popped up, endless loading, but noc crash yet
Win98SE, 512MB RAM, DSL

Java Plug-in 1.5.0
Verwendung der JRE-Version 1.5.0-beta2 Java HotSpot(TM) Client VM

stopping applet
http://www.intrade.com:-1/applet/ContractNames.jsp?id=11738&id=25887&id=87753&id=87745&id=125907&id=142549&id=148926&id=80033&id=25908&id=25894&
Adding: Contract
Adding: Bid
Adding: Ask
Got   12 updated items in 440ms
Exception in thread "Thread-22" netscape.javascript.JSException
	at netscape.javascript.JSObject.getWindow(Unknown Source)
	at com.gsx.web.dmz.applets.MarketData.i.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Got   12 updated items in 490ms
Got   2 updated items in 160ms
Got   2 updated items in 170ms

Comment 7

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040808
Sun Java 1.5.0-beta3-b60

Talkback ID: TB517192G
website is mostly silently crashing, this time Talkback started when staring
browser again.
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB517192G

Stack Signature	 JPINSCP.DLL + 0x2bc0 (0x6d422bc0) a2feca94

Comment 8

14 years ago
Confirming. I believe this bug is related to Bug#250154 : Two symptoms can
occur: either the browser causes a CPU-spin condition (unresponsive), or a
JSException is thrown and the applet quits. Which occurs seems to depend when in
the applet that the JSObject.getWindow() is called (in the start() method or other).

These two symptoms for me only started into the 1.8 betas; 1.7 and earlier work
for me.

The root cause seems to be changes to Mozilla's plugin-scripting architecture:

http://www.mozilla.org/press/mozilla-2004-06-30.html
http://www.mozilla.org/projects/plugins/
http://www.mozilla.org/projects/plugins/npruntime.html 

I too rate this bug as critical, both for the crashing and the fact that some
sites depend _heavily_ on applet-to-javascript interaction (especially signed
applets operations)

Comment 9

14 years ago
Created a bare-bones sample / test-case:

http://kensystem.com/JSObject/

Start Java Consolde (Tools->Web Development), and click on TestJSObject.htm to
launch the applet. Symptom will be either CPU spinning or Java console reporting
a JSException.

Comment 10

14 years ago
This bug seems related to Bug#239857.
To the best of my knowledge this is an old bug in the Sun Java plugin, not a
Mozilla problem. There are other bugs on file with details, though I don't
remember enough about them to find them now. Cc:ing Kyle in case he's got more
input here.
Kyle, any thoughts on this?

Comment 13

14 years ago
Humbly disagreeing - if you install Moz 1.7 (or earlier) the examples work fine...

Comment 14

14 years ago
This doesnt seem to be broken anymore after some combination of variables
recently changed on my system (installed a newer nightly build, copied portions
of an old mozilla profile into a new one to solve some other problems,
un/re-installed java).

So from the few test cases I have to test against, this seems to be fixed now,
or just 'worksforme'... :-)

Comment 15

14 years ago
this is still broken for me, Mozilla crashes silently, or DocWatson coming up,
but not talkback.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a4) Gecko/20040914
Java: JRE1.5RC, though not recommended for Win98
The betas were running better than 1.4.2_05, so I decided to go on installing,
when the 1.5RC installer told me Win98 isn´t supported.
I rarely see Java on the pages I visit, but I´m regularly testing Java crasher
bugs found in Bugzilla, as I´m a bit curious. 
What is the difference between Win98 and Win98SE, regarding the JRE?
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED

Comment 18

12 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20051012 SeaMonkey/1.1a
Java(TM) 2 Platform Standard Edition 5.0 Update 5

reopening: I'm seeing a slow memory leak which will lead to a crash.

Steps to repeat:
1. Load http://www.intrade.com/
2. In the right lower edge is a table, which is showing live share data updated
via Java, or a link 'enable Java on intrade.com'. Click it, if you see it.

Observations:
I don't use adblock or similar plugins.
CPU-Usage hoes to nearly 100%, though the tab interface stays responsible.
Memory usage grows about a Mbyte a minute or so, really slowly.
After maybe 10 minutes UI become very slow, I couldn't copy&paste from about:
memory usage didn't go down when I closed the tab, triggered finalize and
garbage collection in the Java Console and closed java console. 
Memory continued going up when I reopened the page.
Status: RESOLVED → UNCONFIRMED
Keywords: hang
Resolution: EXPIRED → ---

Comment 19

12 years ago
TB10804953X when closing the browser after I filed comment 18

Stack Trace  	
nsDocument::GetPrincipal 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/base/src/nsDocument.cpp,
line 1215]

Comment 20

12 years ago
nsDocument::GetPrincipal was a top crash around 2005-10-13 (maybe before and maybe still) but it's unlikely to be related to this old bug.

A slow memory leak (which I'm not seeing) is also not this bug.  Can you file a new bug for that (a testcase would be nice).

resolving WFM

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ 0x00000000 - gklayout.dll ]
You need to log in before you can comment on or make changes to this bug.