[@ jsd_NewThreadState]

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
15 years ago
a month ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Assignee)

Description

15 years ago
i don't think this is bug 240521

dbaron/jay, could you possibly pull registers and cpu instructions for this
crash? i need more info/it doesn't make sense.

114 jband  3.2      jsdthreadstate = (JSDThreadState*)calloc(1,
sizeof(JSDThreadState));

115 ltabb  1.1      if( ! jsdthreadstate )
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
null check
116                     return NULL;
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
handling for null case
117             
118                 jsdthreadstate->context = cx;
119 jband  3.2      jsdthreadstate->thread = JSD_CURRENT_THREAD();
120                 JS_INIT_CLIST(&jsdthreadstate->stack);
121 ltabb  1.1      jsdthreadstate->stackDepth = 0;
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
line talkback would traditionally mean
122             
123                 while( NULL != (fp = JS_FrameIterator(cx, &iter)) )
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
line referenced by talkback
124                 {
125                     JSScript* script = JS_GetFrameScript(cx, fp);

Incident ID: 512155
Stack Signature	jsd_NewThreadState 8579f215
Product ID	MozillaTrunk
Build ID	2004080607
Trigger Time	2004-08-08 12:20:33.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	jsd3250.dll + (00002da1)
URL visited	
User Comments	can't convert Error to String. going back with dom inspector
sidebar open. some fairly complicated js was run as chrome a couple of times and
venkman was running
Since Last Crash	55951 sec
Total Uptime	55951 sec
Trigger Reason	Access violation
Source File, Line No.
c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/jsd/jsd_stak.c,
line 123
Stack Trace 	
jsd_NewThreadState 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/jsd/jsd_stak.c,
line 123]
jsd_CallExecutionHook 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/jsd/jsd_hook.c,
line 169]
jsd_DebugErrorHook 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/jsd/jsd_high.c,
line 378]
ReportError 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jscntxt.c,
line 345]
js_ReportErrorNumberVA 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jscntxt.c,
line 632]
JS_ReportErrorNumber 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsapi.c, line
3958]
js_DefaultValue 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsobj.c, line
3224]
js_ValueToString 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsstr.c, line
2656]
XPCConvert::JSValToXPCException 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcconvert.cpp,
line 1240]
nsXPCWrappedJSClass::CheckForException 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp,
line 829]
nsXPCWrappedJSClass::CallMethod 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp,
line 1371]
nsXPCWrappedJS::CallMethod 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp,
line 450]
PrepareAndDispatch 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 119]
SharedStub 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 147]
nsObserverService::NotifyObservers 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsObserverService.cpp,
line 210]
XPTC_InvokeByIndex 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2030]
XPC_WN_CallMethod 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1288]
js_Invoke 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 1283]
js_Interpret 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 3377]
js_Invoke 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 1302]
nsXPCWrappedJSClass::CallMethod 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp,
line 1338]
nsXPCWrappedJS::CallMethod 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp,
line 450]
PrepareAndDispatch 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 119]
SharedStub 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 147]
nsBrowserStatusFilter::OnStateChange 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/browser/src/nsBrowserStatusFilter.cpp,
line 140]
nsDocLoaderImpl::FireOnStateChange 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/uriloader/base/nsDocLoader.cpp,
line 1232]
nsDocLoaderImpl::doStopDocumentLoad 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/uriloader/base/nsDocLoader.cpp,
line 868]
nsDocLoaderImpl::DocLoaderIsEmpty 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/uriloader/base/nsDocLoader.cpp,
line 765]
nsDocLoaderImpl::OnStopRequest 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/uriloader/base/nsDocLoader.cpp,
line 695]
nsLoadGroup::RemoveRequest 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/netwerk/base/src/nsLoadGroup.cpp,
line 704]
HandleImagePLEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/base/src/nsImageLoadingContent.cpp,
line 646]
PL_HandleEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 693]
PL_ProcessPendingEvents 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 631]
_md_EventReceiverProc 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 1434]
USER32.dll + 0x3d79 (0x77d43d79)
USER32.dll + 0x3ddf (0x77d43ddf)
nsAppShellService::Run 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 489]
main1 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1331]
main 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1801]
WinMain 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1827]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e814c7)

notes:
1. i ran hsRecord.js a few times in this session.
2. none of my c++ components are in this session because it's a mozilla.org
nightly :).
3. the replay button hook patch to chrome was applied (it's required to allow
the execution of arbitrary scripts, f.e. hsRecord.js in chrome context).
4. i ran a few other recordings generated by other people in this session
5. i installed the dom inspector sidebar by using the button in preferences. the
sidebar tends to trigger an error or so per page load (not sure why)
6. there's a console-logger.js0 in components/ but it /shouldn't/ be loaded as
its extension is current.

based on the stack trace, this should be a crash coming from either a recorder
or a recording (it's hard to tell the difference, they're essentially the same).

Likely sequence of events:
1. can't convert Error to String appears in venkman
2. i click the back button in a window which is monitored by one or more
recorders/players.
3. a load notification for any of sidebar or that window is triggered which
reaches one of those recorders/players.
4. bad things happen at 3 because js is already wedged (see 1).

Filing as unconfirmed because i can. This stack trace is not something i'm used
to seeing, and i am familiar with quite a few interesting crashes.
(Assignee)

Comment 1

15 years ago
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=513403

this time i didn't install the domi sidebar, although it was open.
Product: Core → Other Applications
INCOMPLETE:  Three years old, unco, no clear steps to reproduce, requires proprietary code.  Please reopen if you can reproduce this on trunk, with clear steps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
Crash Signature: [@ jsd_NewThreadState]

Updated

a month ago
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.