internetsearchservice should listen to browser.search.defaultenginename's pref value changed

RESOLVED INVALID

Status

SeaMonkey
Preferences
RESOLVED INVALID
14 years ago
4 years ago

People

(Reporter: Boying Lu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

3.93 KB, patch
neil@parkwaycc.co.uk
: review-
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
Currently Mozilla Internet searching service uses two preferences
"browser.search.defaultenginename" and "browser.search.defaultengine". 
And they are not sync up. I.e. user can set "browser.search.defaultengine" to
google while "browser.search.defaultenginename" to "netscape search".

I think these two preferences need to be synced up. I.e. they should point to a
same search engine. So administrator can set only
"browser.search.defaultenginename" instead of "browser.search.defaultengine"
whose  content is not as straightforward as "browser.search.defaultenginename".
(Reporter)

Comment 1

14 years ago
Created attachment 155536 [details] [diff] [review]
patch v0
(Reporter)

Comment 2

14 years ago
Comment on attachment 155536 [details] [diff] [review]
patch v0

Can you give r?
Thanks
Attachment #155536 - Flags: review?(jag)
Product: Browser → Seamonkey
(Reporter)

Comment 3

13 years ago
*** Bug 308443 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

13 years ago
Attachment #155536 - Attachment is obsolete: true
Attachment #155536 - Flags: review?(jag) → review-
(Reporter)

Comment 4

13 years ago
Created attachment 196289 [details] [diff] [review]
a new proposal
Attachment #196289 - Flags: review?(neil.parkwaycc.co.uk)

Comment 5

13 years ago
Comment on attachment 196289 [details] [diff] [review]
a new proposal

Well, at the very least, engineRes can be computed via
rdf.GetResource(defaultengine);
But I don't see why you need to do that update, surely the defaultengine to
defaultenginename update already works?
Attachment #196289 - Flags: review?(neil.parkwaycc.co.uk) → review-
(Filter "spam" on 'prefs-nobody-20080612'.)
Assignee: prefs → nobody
QA Contact: prefs

Comment 7

4 years ago
Closing as INVALID. Search service is now using OpenSearch
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.