Add "cc" to supported fields in bug_email.pl

RESOLVED WORKSFORME

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: David Fallon, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040612 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040612 Firefox/0.8

I needed to have bug_email.pl support a "cc" field, and created a patch to fix
it. I'm testing it now, and will post it shortly, but figured I'd post this bug
to make sure there wasn't a better way to do it, or anything I should be doing
to make it more likely this gets patched. The patch also adjusts the bug_email
documentation (bugmail_help.html) to describe the new field.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 155721 [details] [diff] [review]
patch to resolve bug

Here's the decently tested patch. Relatively straightforward, and a nice
addition for folks.
(Reporter)

Comment 2

14 years ago
any chance of anyone looking at this? I'd hate to have the patch become useless
because time has passed... 

Updated

14 years ago
Attachment #155721 - Flags: review?(kiko)

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 3

14 years ago
Comment on attachment 155721 [details] [diff] [review]
patch to resolve bug

It's unacceptable to have in /contrib code that initializes a hash (%ccids) 
based on $Control{'cc'} and to introduce code redundancy and duplication.

I'd remove said code from post_bug.cgi and move it into one of those
Bugzilla/*.pm files. Then have it called from both bug_email.pm and
post_bug.pm. 

As a nit, SendSQL is depreciated and $dbh-> methods should be used instead.
Attachment #155721 - Flags: review?(kiko) → review-
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → general
QA Contact: mattyt-bugzilla → default-qa

Updated

13 years ago
Blocks: 322955

Comment 5

13 years ago
Created attachment 208876 [details] [diff] [review]
Alternate difference

This difference handles obtaining the CC in a different manner than was originally applied to this bug. It also has some options for updating bug_email.pl's getEnumList function such that it works with the new Bugzilla 2.20 schema.
I hope this code proves to be useful.

Comment 6

10 years ago
email_in.pl already supports @newcc and @cc. bug_email.pl is dead.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.