Attachment name becomes garbage by mozilla -compose attachment=file:///<multibyte text>

RESOLVED DUPLICATE of bug 210445

Status

MailNews Core
Internationalization
RESOLVED DUPLICATE of bug 210445
14 years ago
10 years ago

People

(Reporter: Shinichi Hanaki, Assigned: smontagu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; ja-JP; rv:1.4) Gecko/20040414
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; ja-JP; rv:1.4) Gecko/20040414

When I try to compose e-mail with attachment by
"mozilla -compose attachment=file:///tmp/<multibyte filename> in non UTF-8 locale,
compose window is launched without attachment name.
When I focus the mouse on the attachment field,
the garbled text is displayed.


Reproducible: Always
Steps to Reproduce:
1. Login your desktop system as non UTF-8 locale
2. mozilla -compose attachment=file:///<PATH to multibyte filename>
3.

Actual Results:  
Attachment name is not displayed in compose window or
it becomes garbage.

Expected Results:  
Attachment name is displayed correctly as you specified in command line.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 210445 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.