TypeError: Components.classes['@mozilla.org/wallet/wallet-service;1'] has no properties'' thrown from function prefillTextBox(target=HTMLInputElement:{0}) in <chrome://communicator/content/contentAreaClick.js> line 56.

RESOLVED DUPLICATE of bug 238733

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 238733
14 years ago
10 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.19 KB, patch
neil@parkwaycc.co.uk
: review+
dveditz
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

14 years ago
TypeError: Components.classes['@mozilla.org/wallet/wallet-service;1'] has no
properties'' thrown from function prefillTextBox(target=HTMLInputElement:{0}) in
<chrome://communicator/content/contentAreaClick.js> line 56.

I'm not building wallet, but xpfe depends on it and causes exceptions which
bubble up to my code. this is a bad thing.

#0: function prefillTextBox(target=HTMLInputElement:{0}) in
<chrome://communicator/content/contentAreaClick.js> line 56
#1: function hrefForClickEvent(event=Event:{0}) in
<chrome://communicator/content/contentAreaClick.js> line 140
#2: function contentAreaClick(event=Event:{0}) in
<chrome://communicator/content/contentAreaClick.js> line 177
#3: dispatchEvent in x-jsd:native-code
#4: function click(params=Object:{18}) in
<file:/C:/Documents%20and%20Settings/Administrator/Desktop/129.js> line 662
(Assignee)

Comment 1

14 years ago
Created attachment 155623 [details] [diff] [review]
check for wallet
(Assignee)

Updated

14 years ago
Attachment #155623 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED

Comment 2

14 years ago
Comment on attachment 155623 [details] [diff] [review]
check for wallet

It would be nice to change .value.length to .textLength as well.
Attachment #155623 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Assignee)

Updated

14 years ago
Attachment #155623 - Flags: superreview?(dveditz)
Comment on attachment 155623 [details] [diff] [review]
check for wallet

sr=dveditz
Attachment #155623 - Flags: superreview?(dveditz) → superreview+
(Assignee)

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 238733 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: form.manager
You need to log in before you can comment on or make changes to this bug.