Run time error displaying dependency tree if no dependent bugs in IE 6.0

RESOLVED DUPLICATE of bug 308666

Status

()

--
minor
RESOLVED DUPLICATE of bug 308666
14 years ago
6 years ago

People

(Reporter: schuldy, Assigned: kiko)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 

In the file "template/en/default/bug/dependency-tree.html.tmpl on line 119
there is an unnecessary trailing comma on the line as below:
    var Node = { TEXT_NODE: 3, };

In IE 6.0, this causes a run-time error report when displaying the generated
page.  Removal of that comment resolves the issue.

Reproducible: Always
Steps to Reproduce:
1. Create a bug with no dependencies
2. Display the bug.
3. Select "Show dependency tree" when there are no dependents

Actual Results:  
As mentioned, IE complains that the page has a problem on line 292 column 32

Expected Results:  
Well, without the stray comma, the interpreter would be happy.

All of this was on a brand new vanilla install, on bug number 1.
(Assignee)

Comment 1

14 years ago
Ouch. 
Assignee: justdave → kiko
Status: UNCONFIRMED → NEW
Ever confirmed: true
duping to newer bug, but one with a patch.

*** This bug has been marked as a duplicate of 308666 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.