Closed Bug 254967 Opened 18 years ago Closed 18 years ago

linux trunk build crashes on launch [@ nsCaret::Init() ]

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
blocker

Tracking

()

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: bryner)

References

Details

(4 keywords)

Crash Data

Attachments

(1 file)

found using both installer and non-installer versions of 2004080912-trunk
firefox builds. when the installer autolaunches firefox --or I issue ./firefox
in a shell-- the app crashes.

pls reassign as needed...

http://talkback-reports.mozilla.org/talkback/quicksearch.jsp?search=2&type=iid&id=522129

Stack Signature	 nsCaret::Init() 4e18c08a
Product ID	FirefoxTrunk
Build ID	2004080910
Trigger Time	2004-08-09 17:03:49.0
Platform	LinuxIntel
Operating System	Linux 2.6.6-1.435.2.3
Module	firefox-bin + (0024a82b)

Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.
/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/layout/base/src/nsCaret.cpp,
line 710
Stack Trace 	
nsCaret::Init() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/layout/base/src/nsCaret.cpp,
line 710]
PresShell::Init() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 710]
nsDocument::doCreateShell() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsDocument.cpp,
line 1300]
nsHTMLDocument::CreateShell() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/html/document/src/nsHTMLDocument.cpp,
line 417]
DocumentViewerImpl::InitPresentationStuff() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsDocumentViewer.cpp,
line 637]
DocumentViewerImpl::InitInternal() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsDocumentViewer.cpp,
line 857]
DocumentViewerImpl::Init() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsDocumentViewer.cpp,
line 624]
nsDocShell::SetupNewViewer() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 710]
nsDocShell::Embed() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 692]
nsDocShell::CreateAboutBlankContentViewer() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 704]
nsDocShell::EnsureContentViewer() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 4453]
nsDocShell::GetInterface() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 704]
nsGetInterface::operator() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/glue/nsIInterfaceRequestorUtils.cpp,
line 710]
nsCOMPtr_base::assign_from_helper() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/glue/nsCOMPtr.cpp,
line 114]
GlobalWindowImpl::GetDocument() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 1392]
nsWindowWatcher::URIfromURL() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 704]
nsWindowWatcher::OpenWindowJS() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 498]
nsWindowWatcher::OpenWindow() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 457]
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2027]
XPC_WN_CallMethod() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 1281]
js_Interpret() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 3376]
js_Invoke() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 1301]
nsXPCWrappedJSClass::CallMethod() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp,
line 1336]
nsXPCWrappedJS::CallMethod() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp,
line 450]
PrepareAndDispatch() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_gcc_x86_unix.cpp,
line 100]
xre_main() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 710]
main() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 59]
libc.so.6 + 0x14ad4 (0x00ac0ad4)
also get the following in the shell:

$ ./firefox
./run-mozilla.sh: line 423:  2612 Segmentation fault      "$prog" ${1+"$@"}
Summary: linux trunk build crashes on launch → linux trunk build crashes on launch [@ nsCaret::Init() ]
Seeing the same thing, but when trying to launch mozilla, not firefox :|
Keywords: topcrash+
using Firefox, this regressed btwn the 2004080712-trunk (fine) and
2004080812-trunk (broken) builds.
Keywords: regression
caillon, any chance this is your gtk2 widget factory changes?  nsCaret::Init()
is fairly null-safe, but not on the bidikeyboard service... I'm wondering if
somehow that's not registered now.

cc'ing mats as well for TextControlFrame changes in the regression window (8/7-8/8).
Assignee: bryner → caillon
Attached patch patchSplinter Review
Attachment #155844 - Flags: review?(shaver)
Comment on attachment 155844 [details] [diff] [review]
patch

I suppose this is technically my fault. r=shaver
Attachment #155844 - Flags: review?(shaver) → review+
Assignee: caillon → bryner
checked in.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
*** Bug 255246 has been marked as a duplicate of this bug. ***
*** Bug 265103 has been marked as a duplicate of this bug. ***
Aviary still crashing. Please see bug 265103 comment 13. Does this just need
branch checkin? If so, someone please nominate.
Crash Signature: [@ nsCaret::Init() ]
You need to log in before you can comment on or make changes to this bug.