Plastikfox theme for Mozilla Update

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Administration
--
enhancement
RESOLVED FIXED
14 years ago
2 years ago

People

(Reporter: Víctor Fernández, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7) Gecko/20040623
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7) Gecko/20040623

Theme name: Plastikzilla Crystal SVG
Theme version: 1.2.1
Description: "Plastikfox is a theme for Mozilla Firefox to make it have the same
look as the KDE programs with the Plastik style and the Crystal SVG 1.0 icon set."

Supported Firefox versions: 0.7 - 0.9+
Theme author: Víctor Fernández Martínez
Homepage: http://www.polinux.upv.es/mozilla/

Link to the JAR file:
http://www.polinux.upv.es/mozilla/plastikfox/jar/plastikfox.jar
File size: 775,9 KB
Screenshot: http://www.polinux.upv.es/mozilla/plastikfox/texturizer/plastikfox.png

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Ooops! The theme name is "Plastikfox Crystal SVG" instead of "Plastikzilla
Crystal SVG".

Updated

14 years ago
Assignee: psychoticwolf → Bugzilla-alanjstrBugs
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
The only thing that I think needs work are the tabs.  This is now in the
reviewer's queue.
Status: NEW → ASSIGNED
Whiteboard: In queue

Comment 3

14 years ago
Hovering over menu items causes other items to shift left and right.  Did you
forget to do a transparent border?

Comment 4

14 years ago
Mirroring can take up to 30 minutes.  If you release a new version, please
reopen this bug; it saves me a lot of hassle.  Bug 254925 is so you can update
it yourself.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

14 years ago
Theme updated to the version 1.2.2. The link is the same.

File size is now 800.874 bytes (782,1KB).
Md5sum: 521ac8edfe97d740d56aee8708508c12
(Reporter)

Comment 6

14 years ago
alanjstr, are you using Tabbrowser extensions? Plastikfox isn't compatible with
Tabbrowser extensions right now. About the menu items, of course I use a
transparent border. I have never seen any strange effects in the menus in any of
my tests.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

14 years ago
Yes, I use TBE.  This is the first time I've heard of a theme conflicting with it.
Status: REOPENED → ASSIGNED
Whiteboard: In queue
(Reporter)

Comment 8

14 years ago
This is due to the tab widget binding. I need to bind the tab widget to tell
Firefox how to display it because it's more complex as in other themes.
Tabbrowser extensions also bind the tab widget and they "overwrite" what I bind
in the theme thus making it work incorrectly. I still haven't found a way to
avoid this problem.

Comment 9

14 years ago
If I disable TBE and restart, will that work?  Or do I have to uninstall it.

Comment 10

14 years ago
(In reply to comment #9)
> If I disable TBE and restart, will that work?  Or do I have to uninstall it.

You should not be testing extensions/themes with a profile w/ TBE installed. :-)

Comment 11

14 years ago
To the contrary.  Many people use TBE and need to know that these do not get
along.  Extensions and themes must play well with others, or they get a note added.
(Reporter)

Comment 12

14 years ago
Well, I added a note in the page where the theme was originally published:

http://www.kde-look.org/content/show.php?content=11442

It says:

"TABBROWSER EXTENSIONS: Due to the way Tabbrowser extensions handles the tabs,
Plastikfox won't work correctly with these extensions. There's an experimental
mod of the Tabbrowser extensions to allow compatibility with Plastikfox.
Currently it's in very early alpha stage and may or may not work for you, but
you can download and test it. It's available here:
- http://www.polinux.upv.es/mozilla/plastikfox/tabbrowser/tabextensions.jar"

Could you add this note (or a similar one) to the theme description?

Updated

14 years ago
Whiteboard: In queue
(Reporter)

Comment 13

14 years ago
I've just released the new version 1.3. It fixes an important bug that made
Firefox crash when visiting certain web pages. Please update the jar file as
soon as possible. The link is the same:

http://www.polinux.upv.es/mozilla/plastikfox/jar/plastikfox.jar

New file size: 786.076 bytes (767,7 KB)

Updated

14 years ago
Summary: Plastikzilla theme for Mozilla Update → Plastikfox theme for Mozilla Update
Whiteboard: In queue

Updated

14 years ago
Whiteboard: In queue

Comment 14

14 years ago
Please reopen this bug if you have an update.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

14 years ago
New release: Plastikfox Crystal SVG 1.4.

This release solves many of the problems related to Tabbrowser extensions. There
are still a few but not many important and now it's much better. So you can
remove the message saying it's not compatible with TBE. The URL is the same as
before:

http://www.polinux.upv.es/mozilla/plastikfox/jar/plastikfox.jar

It's compatible up to Firefox 0.9.x. I haven't added compatibility for Firefox
1.0PR yet, but I will do it in the next release.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

14 years ago
Status: REOPENED → ASSIGNED
Whiteboard: In queue

Comment 16

14 years ago
If you have any theme category suggestions, let me know.
Whiteboard: In queue

Comment 17

14 years ago
We may be experiencing a temporary problem with it linking to the wrong URL. 
Other than that, this is fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

14 years ago
Hi! The theme should now be compatible with TBE, so could you please remove the
message "Not compatible with TBE" from the theme description? Thanks!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

14 years ago
Status: REOPENED → ASSIGNED
Whiteboard: In queue

Updated

14 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 19

14 years ago
Theme updated:

Plastikfox Crystal SVG 1.5
http://www.polinux.upv.es/mozilla/plastikfox/jar/plastikfox.jar

NEW: Added support for Firefox 1.0PR.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 20

14 years ago
the maxver says 0.10, right?
(Reporter)

Comment 21

14 years ago
No, it says "1.0". I tried with 0.10 but it didn't work for me.

Comment 22

14 years ago
It should say 0.10, for now.
(Reporter)

Comment 23

14 years ago
Ok, I've updated the jar file changing 1.0 for 0.10. The last time I tested it,
it didn't work, but I've tested it now and it works, so probably I made a
mistake but now it's ok.

Updated

14 years ago
Status: REOPENED → ASSIGNED
Whiteboard: In queue

Comment 24

14 years ago
Please clear the status whiteboard when reopening.  These have all been checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 25

14 years ago
Theme updated to the new version 1.5.1.

http://www.polinux.upv.es/mozilla/plastikfox/jar/plastikfox.jar

minVersion: 0.8
maxVersion: 1.0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: In queue

Updated

14 years ago
Status: REOPENED → ASSIGNED
Whiteboard: In queue

Comment 26

14 years ago
According to the status whiteboard and the approval queue, your item has been
approved.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Component: Update → Listings
Product: mozilla.org → Update
Version: other → unspecified
(Reporter)

Comment 27

14 years ago
The theme is currently listed in the category "Miscellaneous". Could you put it
in the category "OS Integration"?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: In queue

Updated

14 years ago
Assignee: Bugzilla-alanjstrBugs → nobody
Status: REOPENED → NEW

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 28

13 years ago
I have created an account at the Developer Control Panel with the e-mail address
"vfernandez@polinux.upv.es". Could you transfer the theme to my new account?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → FIXED
The evil bugspam monkeys have attacked again, updating the QA Contact for all Add-ons :: Add-ons bugs (renamed from Listings). Please ignore and go back to work at your cubicle.
QA Contact: mozilla.update → add-ons
Component: Add-ons → Administration
QA Contact: add-ons → administration
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.