Closed Bug 254998 Opened 16 years ago Closed 16 years ago

Caret tracking fails to reach much (most?) of the document in a reasonable fashion

Categories

(Core :: Disability Access APIs, defect)

1.7 Branch
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 241023

People

(Reporter: korn, Assigned: ginnchen+exoracle)

References

()

Details

(Keywords: access, Whiteboard: AP1)

1. Launch Mozilla
2. Go to http://www.sun.com
3. Press F7 to turn on caret browsing mode
4. Press TAB once to get into the document, at roughly the beginning
5. Discover that it is virtually impossible to reach all of the document just by
using the caret (arrow keys, Ctrl-arrow keys, etc.).  
 a. Using down arrow alone only reaches a small portion of the left column (see
bug #254997)
 b. Using Ctrl-Right-arrow to read by word only gets to the end of the first
line (ending in the search button).  Note: the way it reads by word is also
broken (subject of a bug to be filed shortly...).
 c. Once you reach the end of the top-most line, down arrow does nothing
 d. If you think to press down arrow when in the middle of the top line, at say
somewhere in the middle of the words/link "How To Buy", you get several blank
lines where the caret is hidden, and then you reach the text/link "see all
features >>", skipping over huge portions of the document
Whiteboard: AP1
Blocks: caretnav
Ginn, if there's no new information here, just mark it a dup of bug 241023.
Assignee: aaronleventhal → ginn.chen
OS: Linux → All
Hardware: Sun → All

*** This bug has been marked as a duplicate of 241023 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.