"firefox ." apparently attempts network connection

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: mattr, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

You would think that the command "firefox ." would open the current directory in
the file browser. Also seems that ./ doesn't work but /. does.. :)

First time I ran this, I got a dialog box which said something to the effect of
"Could not access www.." and the dialog flashed extremely quickly many times.
This may be due to a temporary network outage I experienced on recovering from
laptop sleep mode with a pppoe connection (it did not flash after fixing the
connection).

Security-bounty-wise, this might cause network traffic you don't want, or
theoretically maybe if there was a funny dns it could even redirect you
somewhere you don't want to go today.

The other half of the error is that to confirm this I tried to run firefox .
again while this bug reporting window was open. I couldn't because I didn't want
to make a new profile.  Normally I would expect running firefox again to at
least open another window, whether technically of the same session or not I
don't care.  

Finally another bug. When I view a Japanese email listing in the buggy Open
Webmail package used by some ISPs, sometimes the bitmaps of Japanese subject
lines are completely destroyed at a pixel level (like someone rubbed an eraser
through them until illegible). This could either be a memory problem or
something else but such a display should never happen, indeed no other software
I know has ever created such a display.  Which is too bad since I like firefox a
lot!  Ganbare! (Good luck!) mattr atnospam telebody dotddddotcom.


Reproducible: Always
Steps to Reproduce:
1. optionally turn off networking
2. type "firefox ."
3. enjoy the fireworks

Actual Results:  
fireworks (like a dialog flashing 100 times in 3 seconds). Otherwise fine.

Expected Results:  
Show me the current directory as a file browser listing.

running redhat 9 linux on dell inspiron 7500 pentium III.
I think it is a major problem, you may not. If you do, how about the bounty?

Comment 1

14 years ago
I can confirm your first bug.  Running "firefox ." tries to load "http://./",
which is not DWIM.

The "other half" of your bug has been fixed (bug 177996), and will be in 1.0.
The third half of your bug is difficult to analyze.  Please open another bug
report, and attach a screenshot and a URL or HTML source that shows the problem.

In the future, please submit separate bugs for separate problems.
(Changing bug summary, changing severity to minor.)
Severity: major → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: "firefox ." apparently attempts network connection. Also: can't reenter profile. And Japanese messed. → "firefox ." apparently attempts network connection
firefox isn't really a file browser, its not Konqueror, nor does it aspire to
be.  I'm not sure if this is really valid, or if its worth trying to fix this in
some way.

Comment 3

14 years ago
Hey, and "firefox $PWD" or "firefox `pwd`" will do what the reporter wants.

I can see this functionality at least being worthwhile.  If you have a webpage
on your hard drive that you'd like to navigate, "firefox ." is probably the
first thing you'd think to type.

Comment 4

14 years ago
I had the same problem with "firefox.exe foo.html".

Comment 5

13 years ago
This WFM on Windows with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060407 Firefox/3.0a1 ID:2006040704

Reporter, does this bug still exist with a current version of Firefox?
(Reporter)

Comment 6

13 years ago
Hello, and thank you everyone who took the time to look at my bug!

I just tried it with my current firefox version which is 1.0.7 on linux rh9. (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7).

Looks like it is fixed.  typing "firefox ." at the command line causes the rightmost tab of the currently running firefox instance to open the current directory.

Matt

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.