color of select field does not update when new item is selected

RESOLVED DUPLICATE of bug 79107

Status

()

Core
Layout: Form Controls
--
trivial
RESOLVED DUPLICATE of bug 79107
14 years ago
14 years ago

People

(Reporter: trevor, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

When drawing a select field that has different colors for each option the color
of the menu does not update when a new option is selected.  In the following
example the select field will stay red regardless of the option selected.
Example code: <select name=somefield style="color:red"><option name=foo
style="color:blue">foo</option><option name=bar
style="color:green">bar</option></select>

Reproducible: Always
Steps to Reproduce:
1. Create a website with a select field that has a different color for each option
2. Change the selected option
3.

Actual Results:  
color stays as the same as the defined color for the select field (if this is
left blank then the color will always stay black or the color of the default
selected option)

Expected Results:  
should update color to match newly selected option

This is fairly trivial, and I was able to work around it by including javascript
to update the colors, but since it works correctly in IE without additional
script I thought that I would bring it to your attention.

Comment 1

14 years ago
Could you please attach a minimized testcase to illustrate the problem, thanks.
Assignee: firefox → nobody
Component: General → Layout: Form Controls
Product: Firefox → Browser
QA Contact: firefox.general → core.layout.form-controls
Version: unspecified → Trunk

*** This bug has been marked as a duplicate of 79107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.