Automatically detect mirrors pages and offer swarming download

RESOLVED DUPLICATE of bug 255053

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED DUPLICATE of bug 255053
14 years ago
9 years ago

People

(Reporter: Full Decent, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Mozilla/Firefox should be able to automatically detect when a page contains
links to mirrors of the same file, for example:
http://linuxiso.org/viewmirrors.php/565

If the user clicks any of those links, it should offer to download using
swarming from a number of the mirrors.

--or--

If the user clicks to download a file, and a file is already downloading with
the same name, the download manager should offer to swarm.

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 255053 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.