Find again (F3) during hidden/closed find toolbar doesn't show toolbar again

RESOLVED INVALID

Status

()

Toolkit
Find Toolbar
--
minor
RESOLVED INVALID
14 years ago
10 years ago

People

(Reporter: Ger Teunis, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040810 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040810 Firefox/0.9.1+

Find again should always reopen the find toolbar again?
Currently find again works, but the toolbar is not shown.

Reproducible: Always
Steps to Reproduce:
1. Use CTRL-F to find some text
2. Close Find Toolbar
3. Press F3

Actual Results:  
Find Toolbar not shown.

Expected Results:  
Find Toolbar should be shown again.
(Reporter)

Updated

14 years ago
Summary: Find again (F3) on hidden/closed find toolbar doesn't show toolbar again → Find again (F3) during hidden/closed find toolbar doesn't show toolbar again

Comment 1

14 years ago
Blake: I've just modified Firefox to deal with this properly, I'll submit my
patch tomorrow, when I can make CVS check out a working version of browser.js
which I can use for that purpose.

My patch will also make the Find Toolbar timeout automatically if you used FAYT,
then used a keyboard shortcut for find again (F3 or CTRL+G). The toolbar will,
of course, remain if you use CTRL+F, then F3, CTRL+G or the "next" button.

Comment 2

14 years ago
The current reaction of the find bar to keep the bar hidden using F3 was
recently set with the fix of bug 252960.

It appears the bar remains hidden by design.

Comment 3

14 years ago
The choices to fix that bug were "restore as a temporary toolbar" or "not show
it at all". I think I prefer the first, and it's a relatively simple change.

Comment 4

14 years ago
Created attachment 156496 [details] [diff] [review]
v0.1 - F3 and CTRL+G unhide Find Toolbar

This patch results in the Find Toolbar reacting as follows:

Regular FAYT
------------
1) Start typing. Find Toolbar appears. After the delay, the Find Toolbar hides.

2) CTRL+G or F3... Find Toolbar appears. After the delay, the Find Toolbar
hides.
3) Backspace. Find Toolbar appears. After the delay, the Find Toolbar hides.
4) Start typing something new. Entirely new search is started (previous search
is cleared).

Links Mode
----------
1) Hit the ' key. Find Toolbar appears. Only links are searched. Find Toolbar
does not hide.
2) CTRL+G or F3... Find Toolbar is already visible and does not hide after
delay.
3) Backspace. Find Toolbar still has focus, so a character is deleted.
4) Start typing something new. Find Toolbar still has focus, so appends text to
original search.

CTRL+F or / Mode
----------------
1) Hit the / key or CTRL+F. Find Toolbar appears. Find Toolbar does not hide.
2) CTRL+G or F3... Find Toolbar is already visible and does not hide after
delay.
3) Backspace. Find Toolbar still has focus, so a character is deleted.
4) Start typing something new. Find Toolbar still has focus, so appends text to
original search.

However, if the user can go "back", the backspace key navigates backwards
instead of always bringing up the find toolbar. I can handle this too inside
this bug if you wish, but it should probably be filed as a seperate bug.

Comment 5

14 years ago
Comment on attachment 156496 [details] [diff] [review]
v0.1 - F3 and CTRL+G unhide Find Toolbar

Requesting review. Not sure if SR is needed or who to ask for it.
Attachment #156496 - Flags: review?(firefox)
(Reporter)

Comment 6

14 years ago
First of all: thank you very much Ben for looking into this.

I only have one question (just curious): why is the links search (in fact a FAYT
on links) not auto-hiding?

Comment 7

14 years ago
You now have to manually activate Links Only mode by pressing ', so it'd be
inconsistent to have it automatically hide. I'm not sure if Blake intends to
have a FAYT Links Only mode again, since the preference has been removed from
the Tools > Advanced options.

If Blake (or someone else) patches Firefox to return FAYT Links Only
functionality, I don't think any changes would be required to this patch for it
to work.

Comment 8

14 years ago
Marking INVALID.  This isn't a bug, it's as designed.  When you press F3 in, for
example, Notepad, it doesn't display the Find window again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

14 years ago
Attachment #156496 - Flags: review?(firefox)
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.