SubString search does not work for keywords.

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: jignesh gandhi, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 

it looks for valid keyword even if query is searching for 'substring'

i have keywords

jignesh
jignesh_gandhi

i cannot enter 'esh' for searching these two keywords.
if i enter 'esh' as a keyword itselves,, the query works fine.

this is a bug, where if you are looking at 'substring' in 'keywords' it should 
not search if keywords exists or not.

Reproducible: Always
Steps to Reproduce:
1. create keywords jignesh and jignesh_gandhi
2. in the query page search for keywords "case sensitive substring" like "esh"
3. it will give error "invalid keyword esh"
4. create keyword esh
5. now the same search will work

Actual Results:  
keyword search for case sensitive / insensitive substring is screwed up.

Expected Results:  
if we select 'substring' if should not 'check' if that 'substring' exists as a 
keyword.
(Reporter)

Updated

14 years ago
Version: unspecified → 2.12
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → query-and-buglist
QA Contact: mattyt-bugzilla → default-qa

Comment 2

13 years ago
joel, any idea? This bug has version 2.12. Is this bug still valid?
Severity: major → normal
OS: Windows XP → All
Hardware: PC → All

Comment 3

12 years ago
I can reproduce using 2.21.1+
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Duplicate of this bug: 474150

Comment 5

7 years ago
This works for me, at least on trunk (which will become 4.2) thanks to some refactoring that I did.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.