charset inhertited from previous window where meta-tag is missing, using wrong font family/size

RESOLVED EXPIRED

Status

()

RESOLVED EXPIRED
14 years ago
13 years ago

People

(Reporter: logan+mozilla-bmo, Assigned: smontagu)

Tracking

1.7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

907 bytes, text/html
Details
105.96 KB, image/jpeg
Details
(Reporter)

Description

14 years ago
Pages missing the <meta ... charset=...> bit seem to inherit the value from the
previous page to a new window and the page is displayed with the wrong font
family and size.

The only way I can reproduce this is by going to some page which specifies a
charset, say asahi.com or suprnova.org, then ^N (new-window) and entering
another url like imdb (http://us.imdb.com/title/tt0246578/). Left-clicking
links, or opening links in a new tab seem ok. I'll attach a testcase and a
screenshot to try and better demonstrate.

This affects Mozilla 1.7.2 (gtk1) and Firefox 0.9+ (gtk2) on linux. No problems
on the Windows machine at work. I've had a few people on irc confirm this, but
someone else tell me he had no problems. Nothing special here for font
configuration, created a new profile for testing.

I see bugs 107889, 111217, and 219264, but they deal with frames or tabs, but
may be related. See also bug 246137, which I filed (and later closed), but is
still related.
(Reporter)

Comment 1

14 years ago
Created attachment 155842 [details]
testcase

html from the URL
(Reporter)

Comment 2

14 years ago
Created attachment 155843 [details]
screenshot
(Assignee)

Comment 3

14 years ago
See the latest comments in bug 158285.

Comment 4

14 years ago
IMO a duplicate of bug 158285.

Comment 5

14 years ago
duplicate of bug 158285 or bug 227631

steps from bug 227631 comment 11 still show the problem

This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.