default status bar text changes if closing a tab stops the loading of a page

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Chris Narrikkattu, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

When a page is loading normally, the status bar text reads "Transferring data
from <siteDomain>...". If that tab is closed (NOT the window), the status bar
text remains as "Transferring data from <siteDomain>...", although the page is
no longer loading.

This is a problem because a user could think that Firefox is still loading
something when it isn't.

Reproducible: Always
Steps to Reproduce:
1. make sure the tab bar is opened so you can close the tab
2. navigate to any page (pages with many images or a large size preferred)
3. while the page is loading, close the tab

Actual Results:  
status bar text is "Transferring data from <siteDomain>...", but the page is no
longer loading

Expected Results:  
reset the status bar text to some default value (i.e. "Done")
(Reporter)

Comment 1

13 years ago
correction on steps to reproduce:
step 1 should actually read: "make sure the tab bar is opened with two tabs so
you can close the tab you test on without closing the window"

this correction is needed for those using clean installs
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Summary: status bar text does not change if closing a tab stops the loading of a page → default status bar text changes if closing a tab stops the loading of a page
You need to log in before you can comment on or make changes to this bug.