crash when clicking twice on "save" and the file selection dialog is already open

RESOLVED DUPLICATE of bug 249143

Status

--
critical
RESOLVED DUPLICATE of bug 249143
14 years ago
14 years ago

People

(Reporter: stephanek, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7) Gecko/20040617
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7) Gecko/20040617

when mozilla prompts for an action about a file it cannot handle, I click "save"
then the file selection dialog appears, then if I click save again, with the
file selection dialog still open, then click on save on the file selection
dialog, it crashes

Reproducible: Always
Steps to Reproduce:
1.click on a url not handled (like a .tgz or .zip)
2.click "save" twice
3.close one of the dialogs

Actual Results:  
crashed

Expected Results:  
not crash...

Comment 1

14 years ago
Stephane: Could you provide TalkBack incident ID of your crash?
Severity: normal → critical
Keywords: crash

Comment 2

14 years ago
dup of bug 232497 -> bug 249143 ?

Comment 4

14 years ago
Best solution would be to prevent opening of second file selection dialog. Or
better said close or disable action dialog after first selection.

*** This bug has been marked as a duplicate of 249143 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.