possible enhancement of the integration of the address bar and search bar

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: paspiltoir, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

An little idea :

One single bar for text entry and several icons at the right of this bar (which
has place and the size of the present address bar) for the specific behavior
(search google, google news, dmoz, dict.org, ... customizable of course) 
And the default behavior (when enter) would be go to the specified URL...

An image, if my english is too bad : http://users.skynet.be/fa594421/projetAB.jpg

adventages :

+acess in one clic (in place of two) at customizable services

+a wider text input thus a better view on the querry (for more complex search,
phrases traduction, etc.)

+maybe more intuitive (I have done test on dummy subjects, and they dont see
that they must enter the text and then clic on the little icon and then choose
the search engine)

-----------------------------------

Vive FireFox !

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

14 years ago
Hardware: PC → All

Comment 1

14 years ago
This is similar to what the mozilla apllication suite does. We walked away from
this intentionally.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 2

14 years ago
What was the reason for this - sounds like a good idea, although I haven't seen
Mozilla for a while so don't know how it's implemented there.

Updated

12 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.