Selected option not changing when the option that is selected is changed and the screen is refreshed.

VERIFIED DUPLICATE of bug 46845

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 46845
13 years ago
13 years ago

People

(Reporter: Justin Houchin, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514

I have the following HTML code:

<html>
<head>
<meta content="text/html; charset=ISO-8859-1"
http-equiv="content-type">
<title>test.html</title>
</head>
<body>

<select name="justin">
  <option value=""></option>
  <option value="yes" selected>Yes</option>
  <option value="no">No</option>
</select>

</body>
</html>

You will notice that "yes" is selected on the list. If you pull up is page in
Mozilla, you will see that "yes" is selected on the select list.  Keep mozilla
open and redit the HTML code making the "no" selected instead.  Go back to your
webpage and click the refresh button.  The select list still shows "yes" being
checked.  Click view page source, you will see that "no" is now supposed to be
selected. 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
Once the refresh button was pressed, the select list should have changed to the
corrected selected option.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.