Occasional crash when using phpmyadmin over secure connection [@ nsHTMLTextAreaElement::Select ]

RESOLVED WORKSFORME

Status

()

Core
DOM
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Thomas Rutter, Unassigned)

Tracking

({crash})

1.7 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040811 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040811 Firefox/0.9.1+

I've experienced many crashes using recent branch builds of Firefox, and they
have all been while using phpMyAdmin.

phpMyAdmin is a web-based tool which uses frames.  I use it over a secure connection

I don't know whether this problem is due to the fact it has FRAMES, or it's over
HTTPS, or both.  I've only experienced this using phpMyAdmin.

Reproducible: Sometimes
Steps to Reproduce:
1. Use phpMyAdmin to accomplish typical tasks
Actual Results:  
Sometimes Firefox crashes

Expected Results:  
No crash!

See incident number (talkback crash ID) TB549167Q

Using Windows XP SP1
Firefox aviary branch build 20040811
256 Mb RAM
I had around 5 tabs open at the time

Comment 1

13 years ago
TB549167Q:
nsHTMLTextAreaElement::Select 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/html/content/src/nsHTMLTextAreaElement.cpp,
line 360]
XPTC_InvokeByIndex 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2028]
XPC_WN_CallMethod 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c,
line 941]
js_Interpret 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c,
line 2973]
js_Invoke 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c,
line 958]
js_InternalInvoke 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c,
line 1035]
JS_CallFunctionValue 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsapi.c, line 3673]
nsJSContext::CallEventHandler 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1297]
nsJSEventListener::HandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/dom/src/events/nsJSEventListener.cpp,
line 184]
nsEventListenerManager::HandleEventSubType 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1434]
nsEventListenerManager::HandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1512]
nsGenericElement::HandleDOMEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/base/src/nsGenericElement.cpp,
line 1960]
nsHTMLTextAreaElement::HandleDOMEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/html/content/src/nsHTMLTextAreaElement.cpp,
line 687]
nsEventStateManager::SendFocusBlur 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/events/src/nsEventStateManager.cpp,
line 4294]
nsEventStateManager::SetContentState 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/events/src/nsEventStateManager.cpp,
line 3958]
nsHTMLTextAreaElement::SetFocus 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/html/content/src/nsHTMLTextAreaElement.cpp,
line 301]
nsEventStateManager::ChangeFocus 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/events/src/nsEventStateManager.cpp,
line 2941]
nsEventStateManager::PostHandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/events/src/nsEventStateManager.cpp,
line 1865]
PresShell::HandleEventInternal 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6055]
PresShell::HandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5896]
nsViewManager::HandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/view/src/nsViewManager.cpp,
line 2285]
nsViewManager::DispatchEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/view/src/nsViewManager.cpp,
line 2025]
HandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/view/src/nsView.cpp,
line 79]
nsWindow::DispatchEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1067]
nsWindow::DispatchMouseEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 5261]
ChildWindow::DispatchMouseEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 5511]
nsWindow::WindowProc 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1349]
USER32.dll + 0x3a50 (0x77d43a50)
USER32.dll + 0x3b1f (0x77d43b1f)
USER32.dll + 0x3d79 (0x77d43d79)
USER32.dll + 0x3ddf (0x77d43ddf)
nsAppShellService::Run 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
main 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/browser/app/nsBrowserApp.cpp,
line 58]
kernel32.dll + 0x214c7 (0x77e814c7)

There are 39 incidents, mostly with Firefox on Aviary branch, some with M1.7:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=nsHTMLTextAreaElement%3A%3ASelect

Thomas, have you any idea, what did you do just before crash? Something in form
textarea?
Keywords: crash
Summary: Occasional crash when using phpmyadmin over secure connection → Occasional crash when using phpmyadmin over secure connection [@ nsHTMLTextAreaElement::Select ]
(Reporter)

Comment 2

13 years ago
The crash always occurs when I click a hyperlink.

I cannot remember if the visible page or the destination page had textareas in
them, but it is highly likely.

(Reporter)

Comment 3

13 years ago
I experienced this bug again in the latest nightly (aviary nightly 20040823)
with phpMyAdmin again.

The crash occured when I clicked a link.  I was NOT doing anything in the
textarea, but the page I was on had a textarea visible in it.

I submitted another talkback incident - new incident ID is TB636513M.  Hope this
helps.

Comment 4

13 years ago
TB636513M:
msvcrt.dll + 0x32f43 (0x77c42f43)
nsStorageInputStream::Read 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpcom/io/nsStorageStream.cpp,
line 408]
nsCacheEntryDescriptor::nsInputStreamWrapper::Read 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/netwerk/cache/src/nsCacheEntryDescriptor.cpp,
line 528]
nsStreamCopierOB::FillOutputBuffer 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpcom/io/nsStreamUtils.cpp,
line 531]
nsStreamCopierOB::DoCopy 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpcom/io/nsStreamUtils.cpp,
line 547]
nsAStreamCopier::Process 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpcom/io/nsStreamUtils.cpp,
line 321]
nsAStreamCopier::HandleContinuationEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpcom/io/nsStreamUtils.cpp,
line 393]
(Reporter)

Comment 5

13 years ago
Received the crash again, this time on 20040920 branch build, and on a different
computer to last time (but at the same phpmyadmin location).

New incident ID is TB981093Y - please take a look.

This time, I can tell you what I did, because it happened quite quickly.

1. Go into a phpMyAdmin installation, which is accessed via HTTPS (ie, secure).
2. Select a database on the left hand panel.
3. Select a table in that database in the left hand panel.
4. Click 'browse' in the right hand panel.

The crash happened right after I clicked browse, and before the new page was
able to load.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 7

12 years ago
reopening to move to core
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

12 years ago
Assignee: firefox → general
Component: General → DOM
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.7 Branch

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME

Comment 8

12 years ago
comment 3/comment 4 are probably bug 207846
Crash Signature: [@ nsHTMLTextAreaElement::Select ]
You need to log in before you can comment on or make changes to this bug.