Last Comment Bug 255460 - Purge executables from the wintools package
: Purge executables from the wintools package
Status: RESOLVED DUPLICATE of bug 274221
:
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86 Windows XP
: P3 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 242870
Blocks: 274221
  Show dependency treegraph
 
Reported: 2004-08-12 19:12 PDT by Stephen Walker
Modified: 2007-01-04 16:35 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Stephen Walker 2004-08-12 19:12:44 PDT
gmake, nsinstall, shmsdos, and uname are all executables packaged with the
wintools package; nsinstall is the only one that's required.  What's the history
behind the other files and should they be removed?
Comment 1 cls 2004-08-13 11:59:25 PDT
The other tools are still supported for building standalone NSPR & NSS iirc.  We
should stop referencing wintools.zip period and just distribute nsinstall.exe
separately.
 
Comment 2 Brian Haskin (Janzert) 2004-12-09 12:27:31 PST
To add a little more urgency to this. 

gmake from wintools.zip will not build the source anyway. Which means people
following the directions given on the web pages get an error when they try and
build.

Janzert
Comment 3 Brian Haskin (Janzert) 2004-12-10 13:10:29 PST
Ok, after talking on IRC and doing some experiments here's what I've found so far.

glib-1.2.dll, libIDL-0.6.dll and nsinstall.exe are all necessary to build
mozilla suite. The dlls are required by xpidl.exe. nsinstall.exe is built and
placed in dist/install, but apparently not used or maybe needed before it is built.

gmake: Unnecessary and seemingly broken.

shmsdos: suite and browser build fine with out it. But it's defined as the shell
in directory/c-sdk/config/win32.mk for PR_CLIENT_BUILD_WINDOWS builds. It's also
listed as a requirement in security/coreconf/README. PR_CLIENT_BUILD_WINDOWS is
defined in both nsprpub/makefile.win and security/coreconf/makefile.win.

uname: suite and browser build fine with out it. But cygwin's uname does not
return the same things. The only thing I've seen this affect is @CONFIG_GUESS@
in my objdir definition. I would worry about this affecting some other define
though.

gmodule-1.2.dll and gthread-1.2.dll: suite and browser build fine without them.
gmodule and gthread are both referenced from config scripts. Also gmodule.h is
included from intl/ctl/src/pangoLite/ modules.c and querymodules.c. But I don't
seem to have a gmodule.h anywhere on my system anyway.

Brian
Comment 4 Brian Haskin (Janzert) 2004-12-11 13:19:05 PST
As referenced at http://www.mozilla.org/classic/build/nspbuild.html, gmake,
shmsdos and uname are used by NSPR rather than requiring cygwin. WTC, are those
still correct dependencies for nspr? If so would a seperate nsprtools.zip make
sense?

uname is known to cause errors when building with mingw.

Brian
Comment 5 Brian Haskin (Janzert) 2004-12-12 21:14:56 PST
Ok, it looks like current build instructions for nspr are at
http://www.mozilla.org/projects/nspr/eng-process/build.html also nspr >=4.2
requires cygwin.

wtc, could you comment here on dependencies nspr standalone builds may have with
the current binaries in wintools.zip.

Brian
Comment 6 Brian Haskin (Janzert) 2004-12-12 21:22:18 PST
It's not completely clear but NSS apparently does not need cygwin to build and
relies on wintools gmake.
http://www.mozilla.org/projects/security/pki/nss/nss-3.9/nss-3.9-build.html

Also they note some problems with shmsdos crashing at times
http://www.mozilla.org/projects/security/pki/nss/troubleshoot.html

Finally, it looks like LDAP C SDK also has an option to build without cygwin.

Brian
Comment 7 Wan-Teh Chang 2004-12-21 18:02:51 PST
Hi Brian,

You can remove gmake, shmsdos, and uname from wintools.zip.
Make sure they are archived somewhere so we can still use
them to build very old Mozilla releases.  We only need
nsinstall to build current Mozilla, NSPR, and NSS releases.
Comment 8 Howard Chu 2005-07-12 10:25:26 PDT
(In reply to comment #3)
> gmodule-1.2.dll and gthread-1.2.dll: suite and browser build fine without them.
> gmodule and gthread are both referenced from config scripts. Also gmodule.h is
> included from intl/ctl/src/pangoLite/ modules.c and querymodules.c. But I don't
> seem to have a gmodule.h anywhere on my system anyway.

gmodule seems to be required for something called ctl Complex Thai Language
support. (--enable-ctl). Does anybody use this option?

Comment 9 Benjamin Smedberg [:bsmedberg] 2006-02-05 04:55:06 PST
See bug 242870 comment 35.
Comment 10 Vladimir Vukicevic [:vlad] [:vladv] 2007-01-04 16:35:15 PST
Duping to 274221, as this was done there.

*** This bug has been marked as a duplicate of bug 274221 ***

Note You need to log in before you can comment on or make changes to this bug.