focus set to searchInput textbox on IMAP mail check when MailView is active

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
14 years ago
13 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040802 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040802 Firefox/0.8

When an IMAP mail check is performed, either by pressing CTRL-T or by an
automatic mail check every x minutes, the keyboard focus is set to the "Subject
or Sender contains" text box (searchInput).  It should not change the focus.  If
the Search Bar is disabled (View/Toolbars/Search Bar), focus is blurred.

Reproducible: Always
Steps to Reproduce:
1. Set up an IMAP mail account
2. Click on the Inbox folder of that mail account
3. Ensure the Search Bar is on (View/Toolbars/Search Bar)
3. Using the View dropdown box in the search panel, select an option other than All
4. Select a message in the message list
5. Press CTRL-T, or wait until the next automatic mail check is performed

Actual Results:  
The keyboard focus is now on the searchInput textbox.

Expected Results:  
The keyboard focus should have stayed on the message that you selected in step
4.  This correct behaviour occurs if you perform a mail check with View set to
All, or do the same action using a POP mail account.

I have replicated this on Windows XP and Linux on three different computers. 
It's also really annoying if you always view your e-mail with a filter on!
(Reporter)

Comment 1

14 years ago
The searchInput box is also cleared and the query reset when a check mail is
performed under the conditions described above.  It is not cleared if the View
is set to All or the account is a POP account.

Comment 2

14 years ago
Are you sure this is only for IMAP?  I have seen the focus shift (sometimes) 
with a POP folder selected -- but apparently only when the IMAP account is 
active.  It may be triggered by the "end" of an IMAP transaction -- loading a 
message, as well as checking for new messages.

Did you want to mark bug 231748 as a duplicate of this bug?

This symptom is closely related to bug 191813, which might be fixed by Neil's 
patch to bug 179050.  See also bug 243117 -- while attempting to reproduce that 
symptom, I found that the focus would shift if a QuickSearch or a MailView was 
doing the filtering.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: focus set to searchInput textbox on IMAP mail check when View filter is active → focus set to searchInput textbox on IMAP mail check when MailView is active

Comment 3

14 years ago
Correct, I could not reproduce this bug in my patched build either.
(Reporter)

Comment 4

14 years ago
I applied the patch to the release version of 0.7.3, and it fixed the bug.  The
searchInput box now does not get focus when mail was checked.

However, the currently selected message in the message list gets deselected upon
mail check if View is not set to all.  This problem does not occur when View is
"all" and a search is used.

I found that removing one line fixes this problem, but as this is the first time
I've looked at Mozilla source I'm not sure of the ramifications of this.  The
patch to remove the "else" in line 13 of onEnterInSearchBar() in searchBar.js
(line 158 of 0.7.3 after applying the patch in bug 179050) so that
restorePreSearchView() gets executed regardless of the value of
gDefaultSearchViewTerms.

Could someone confirm that this fixes the problem?  Thanks.
(Reporter)

Comment 5

14 years ago
Sorry, the patch I supplied above will disable MailView filtering on mail check.

Comment 6

14 years ago
In fact, in an unpatched build, getting new messages clears quick search... I
wonder if that's intentional.

Comment 7

14 years ago
*** Bug 231748 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Depends on: 179050
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail

Comment 8

13 years ago
(In reply to comment #6)
> In fact, in an unpatched build, getting new messages clears quick search... I
> wonder if that's intentional.

Not seeing that in TB 1.5b1, POP or IMAP.  Roger Nesbitt, are you still seeing 
this symptom with a current (1.8-branch build) of TB (e.g. 1.5b1) or Seamonkey 
(e.g. 1.0a)?


Note that I've WFM'd bug 191813 and bug 250248; and bug 237811 and bug 255554 
appear to be very similar bugs, which I can't reproduce either.
(Reporter)

Comment 9

13 years ago
This bug was fixed in release 0.9 (if not before.)
Thanks.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 10

13 years ago
No specific bug / patch referenced as the fix.

-> WORKSFORME
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.