Mozilla 1.7.2 fails to import Internet Explorer favorites

RESOLVED DUPLICATE of bug 205483

Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 205483
14 years ago
13 years ago

People

(Reporter: Mac OS X Angel, Assigned: Pierre Chanial)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040719 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040803

On Mac OS X, the first time the user runs Mozilla (with no profile, even), an
"Imported IE Favorites" menu item appears in the Bookmarks menu, however, it is
empty.

Reproducible: Always
Steps to Reproduce:
1. Remove ~/Library/Mozilla
2. Confirm there is an Internet Explorer (5.2.x for Mac) favorites file at:
~/Library/Preferences/Explorer/Favorites.html
3. Run Mozilla

Actual Results:  
Mozilla ran with its default settings (eg: Classic theme, Mozilla start page).
An item is listed in the Bookmarks menu called "Imported IE Favorites", however
it is empty. ie: appears with "(Empty)".

Expected Results:  
Imported the favorites from ~/Library/Preferences/Explorer/Favorites.html

The user can click Bookmarks > Manage Bookmarks, then Tools > Import and locate
the Favorites.html file. The favorites are imported okay, but the "first-run"
behaviour should perform this correctly automatically (or otherwise, if the user
is expected to import them manually, don't generate the "Imported IE Favorites"
sub-folder).

Comment 1

14 years ago
duplicate 205483.

*** This bug has been marked as a duplicate of 205483 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.