All users were logged out of Bugzilla on October 13th, 2018

Status

RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: alex, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Author Name:   Alex Sirota
E-Mail:        alex@elbrus.com

Extension:     FoxyTunes
Version:       0.5

Homepage URL: http://www.foxytunes.org/firefox/
URL to XPI:   http://www.foxytunes.org/firefox/FoxyTunes_0.5.xpi
OS:           Contains compiled code (XPCOM) for Windows and Linux, works 
              transparently on both platforms
Target App:   Firefox 0.9+

Description:
Control any media player from Firefox and more...
Supported players - Windows: Windows Media Player, WinAmp, iTunes, Musicmatch
Jukebox, Apollo, Sonique, Quintessential Player, foobar2000, other multimedia
players; Linux: XMMS, Noatun.



Reproducible: Always
Steps to Reproduce:

Updated

14 years ago
Assignee: psychoticwolf → Bugzilla-alanjstrBugs
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Status: NEW → ASSIGNED

Comment 1

14 years ago
Jed -
You have to reassign to yourself before you click Accept
Assignee: Bugzilla-alanjstrBugs → jedsbugs
Status: ASSIGNED → NEW

Comment 2

14 years ago
Damn it. Sorry I though I did.

Alex, it's in the queue. Should apear really soon now.
Status: NEW → ASSIGNED
Whiteboard: in queue
(Reporter)

Comment 3

14 years ago
Please change the description of this extension at UMO.

New description:
--------------------------------------------------------
Control any media player from Firefox and more... [Windows/Linux]
<BR>
Supports Windows Media Player, WinAmp, iTunes, Musicmatch, Apollo, Sonique,
Quintessential, foobar2000, J. River, jetAudio, MediaMonkey, Media Player
Classic, Real Player, UltraPlayer, XMMS, Noatun and other players.
--------------------------------------------------------

Please insert the break after the first line, it's important.

Similar break in the desctription exists for the ChatZilla extension:
      http://update.mozilla.org/extensions/moreinfo.php?id=16&vid=510&category=

Thanks a lot,
Alex

Updated

14 years ago
Whiteboard: in queue
(Reporter)

Comment 4

14 years ago
update.mozilla.org seems to have lost all the recentrly added extensions 
including FoxyTunes and FirefoxView after the update and the downtime today.

They simply do not appear anywhere.

Direct links show corrupted and partial information.

Comment 5

14 years ago
The record for this extension was lost during last night's upgrade. It needs to
be readded.
(Reporter)

Comment 6

14 years ago
Ok, here's a clean new request:
------------------------------------------------------------------------------

Author Name:   Alex Sirota
E-Mail:        alex@elbrus.com

Extension:     FoxyTunes
Version:       0.51

Homepage URL: http://www.foxytunes.org/firefox/
URL to XPI:   http://www.foxytunes.org/firefox/FoxyTunes_0.51.xpi
OS:           Contains compiled code (XPCOM) for Windows and Linux, works 
              transparently on both platforms
Target App:   Firefox 0.9+

Description:
-----------------------------------------------------------------------------
Control any media player from Firefox and more... [Windows/Linux]
<BR>
Supports Windows Media Player, WinAmp, iTunes, Musicmatch, Apollo, Sonique,
Quintessential, foobar2000, J. River, jetAudio, MediaMonkey, Media Player
Classic, Real Player, UltraPlayer, XMMS, Noatun and many other players.
-----------------------------------------------------------------------------

Please insert the break after the first line, it's important.

Similar break in the desctription exists for the ChatZilla extension:
      http://update.mozilla.org/extensions/moreinfo.php?id=16&vid=510&category=

Also, it seems that the ratings/comments were not lost (I'm looking at the old
direct link) - any chance of recovering that?

Thanks a lot,
Alex

Comment 7

14 years ago
Fixed, again. :-) Give it time for mirroring (if needed).
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

14 years ago
Please update FoxyTunes record at UMO as compatible with 1.0 Preview Release (0.10).

Submitted a request at http://bugzilla.mozilla.org/show_bug.cgi?id=255804 a few
days ago, but the record wasn't updated.

Thanks,
Alex
(Reporter)

Updated

14 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 9

14 years ago
It's been a long while since I've requested the maxVersion to be bumped to 0.10,
and nothing has happened since. 

The extension is virtually invisible on UMO because the default filter is set on
0.10.

If I am doing something wrong here, would someone please drop me a line saying
what's the problem?

Thanks,
Alex

Comment 10

14 years ago
Sorry about that alex.
I am unable to do so, as I don't know how to do it via the admin panel.
I'm re-assigning to Wolf.

(btw: I'm having the same problem with bbcode 0.3 and WebmailCompose 0.5.5)
Assignee: jedsbugs → psychoticwolf
Status: REOPENED → NEW

Comment 11

14 years ago
255804 has been processed (a couple of days ago), so I'm pretty sure this bug is
fixed. (Didn't catch it was reopened for a 0.10 update here as well. oops)
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

14 years ago
Please update this extension at UMO.

Version:       0.61
URL to XPI:    http://www.foxytunes.org/firefox/FoxyTunes_0.61.xpi

Also, please update the description:

****************************************************************
Control any media player from Firefox and more... [Windows/Linux]
<BR>
<BR>
Supports WinAmp, iTunes, foobar2000, Windows Media Player, Musicmatch,
Quintessential, J. River, jetAudio, MediaMonkey, Media Player Classic, Sonique,
wxMusik, Real Player, XMMS, Noatun, Juk, Amarok, Music Player Daemon, Rhythmbox
and many other players.
<BR>
****************************************************************

Please insert the specified breaks in the description, it's important.

Thanks,
Alex
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 13

14 years ago
I'll take this back, free up wolf for other things.
Assignee: psychoticwolf → jedsbugs
Status: REOPENED → NEW

Comment 14

14 years ago
In Queue.
I'm assuming the Thunderbird support is correct?
(it's in your target apps TB 0.7 - 0.8)
Status: NEW → ASSIGNED
Whiteboard: in queue
(Reporter)

Comment 15

14 years ago
> In Queue.
> I'm assuming the Thunderbird support is correct?
> (it's in your target apps TB 0.7 - 0.8)

This is correct.

Jed - how long does the mirroring take?
I don't know whether there is a problem or I shold just wait patiently :)

Alex
(Reporter)

Comment 16

14 years ago
I beleive that this is a temporary problem, but the install link at UMO says:

Object not found! (404 error).

or The requested URL /pub/mozilla.org/extensions/foxytunes/FoxyTunes_0.61.xpi
was not found on this server.


Comment 17

14 years ago
The queue has been approved.  If you get a 404 error, please comment on bug 259282.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

14 years ago
Please update this extension at UMO.

Version:       0.69
URL to XPI:    http://www.foxytunes.org/firefox/FoxyTunes_0.69.xpi

Also, please update the description:
****************************************************************
Do you listen to Music while surfing the Web?
<BR>
Now you can control your favorite media player without ever leaving the browser
and more...
<BR>
<BR>
Supports WinAmp, iTunes, foobar2000, Windows Media Player, Musicmatch,
Quintessential, J. River, jetAudio, MediaMonkey, Media Player Classic, Sonique,
wxMusik, Real Player, XMMS, Noatun, Juk, Amarok, Music Player Daemon, Rhythmbox
and many other players. 
****************************************************************

Please insert the specified breaks in the description, it's important.
Also, this version supports MacOSX so the words "[Windows/Linux]" are no longer
needed.

Also, please note that this version now also supports Mozilla 1.6-1.7, besides
Firefox and Thunderbird.

Thanks,
Alex
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: in queue
(Reporter)

Updated

14 years ago
Summary: Please add the "FoxyTunes" extension to the extension list → Add Extension: FoxyTunes

Comment 19

14 years ago
In Queue.
I could only add the double <br><br> as the current (limited) system only always
for on break to occur.
If you really need two, please reassign this bug to wolf
(psychoticwolf@carolina.rr.com) so that he can make the change at the DB level.
Assignee: jedsbugs → psychoticwolf
Status: REOPENED → NEW
Whiteboard: in queue
(Reporter)

Comment 20

14 years ago
Thanks :)

A couple of additional requests:
1. The Mozilla compatibility says 1.4-1.7 at UMO. This should be 1.6-1.7
2. The -Author- Home Page says http://www.foxytunes.org/firefox/
   Please change this to http://www.iosart.com/firefox/

   Please note that the -Extension- Home Page is fine.

Thanks a lot,
Alex

Comment 21

14 years ago
Fixed, Fixed, Fixed. :-)

Assignee: psychoticwolf → jedsbugs
Whiteboard: in queue

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 22

14 years ago
Thanks a lot Wolf!

I hope I'm not bugging too much, but there are now 3 breaks (<br>) before the
"Supports WinAmp, ...." part (instead of 2), and it looks kinda funny ;)

I know, I'm a bit crazy/perfectionist that way :)

Could you please remove the one extra break, so there are only two left?
Only if you have the time and it's not too difficult.

Again, sorry and thanks! :)
Alex
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

14 years ago
Assignee: jedsbugs → Bugzilla-alanjstrBugs
Status: REOPENED → NEW

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 23

14 years ago
Thanks a lot for all your help guys :)

Please let me know if I'm out of line here...

There are 3 -consecutive- -identical- comments on FoxyTunes:
----------
Won't work! (0 stars)
can not get it to work with I-Tunes. I installed the extension and selected the
player, I-Tunes, and it didn't do jack-!@#$%! Any suggestions?
Posted on 2004-11-01 16:45:57 by Hanada 
----------

The fact that his problem can be easily solved is besides the point, and I do
believe that we must have human moderation (among other things) on UMO (bug
247144). I would agree that one of the three identical comments somehow has it
place over there. But not all three!

I'm working pretty hard on this thig (as I'm sure we all are), and seeing such
things is very frustrating.

Can you please remove the triple postings by Hanada (leaving only the last one
to be fair).

Again please let me know if this is out of line :)

Thanks,
Alex
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 24

14 years ago
Please update this extension at UMO.

Version:       1.0
URL to XPI:    http://www.foxytunes.org/firefox/FoxyTunes_1.0.xpi
New in 1.0:    http://www.foxytunes.org/firefox/allversions.html
               Please note that skins is an external feature and is not really a
part of the extension.

Please update the Mozilla compatibility to 1.6-1.8.
Also, please note that the description shouldn't be changed.

Thanks a lot,
Alex

Updated

14 years ago
Status: REOPENED → ASSIGNED

Comment 25

14 years ago
In Queue.
Let me know if you need the desc changed, etc.
About the comments, I can't help there, you should assign this bug over to wolf
if you want that done, as one would need DB access for that.
Whiteboard: in queue
(Reporter)

Comment 26

14 years ago
The description got messed up somehow...
Should be:
****************************************************************
Do you listen to Music while surfing the Web?
<BR>
Now you can control your favorite media player without ever leaving the browser
and more...
<BR>
<BR>
Supports WinAmp, iTunes, foobar2000, Windows Media Player, Musicmatch,
Quintessential, J. River, jetAudio, MediaMonkey, Media Player Classic, Sonique,
wxMusik, Real Player, XMMS, Noatun, Juk, Amarok, Music Player Daemon, Rhythmbox
and many other players. 
****************************************************************

It was fine with all the breaks and all :)
Please restore it to the above description.

Thanks,
Alex
(Reporter)

Comment 27

14 years ago
Please see my last comment about the wrong description.
I will appreciate the double breaks as they appear in my comment.

Thanks a lot :)
Alex
Assignee: Bugzilla-alanjstrBugs → psychoticwolf
Status: ASSIGNED → NEW

Comment 28

14 years ago
It appears that the description's breaks get clobbered when it's updated. HTML
is, in general, disallowed in descriptions. So if it happens again, you might be
stuck with it. :-)
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
Whiteboard: in queue
(Reporter)

Comment 29

14 years ago
Now it says:
-----------------
Do you listen to Music while surfing the Web?
Now you can control your favorite media player without ever leaving the browser
and more...

Now you can control your favorite media player without ever leaving the browser
and more... 
-----------------

Very bad!!! :)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 30

14 years ago
Hi,
First, thanks a lot for all your help!
I can't wait for the Developer Control Panel, so I won't have to bother you with
these things ;)

The description is still wrong. The double "Now you can control your
favorite..." is gone, but there is no supported players list. 

Please make the description:
****************************************************************
Do you listen to Music while surfing the Web?
<BR>
Now you can control your favorite media player without ever leaving the browser
and more...
<BR>
<BR>
Supports WinAmp, iTunes, foobar2000, Windows Media Player, Musicmatch,
Quintessential, J. River, jetAudio, MediaMonkey, Media Player Classic, Sonique,
wxMusik, Real Player, XMMS, Noatun, Juk, Amarok, Music Player Daemon, Rhythmbox
and many other players. 
****************************************************************

Thanks again,
Alex 

Comment 31

14 years ago
Does anybody know why FoxyTunes is displayed three times on the UMO extensions
front page (3rd, 4th and 5th top rated extension)? :-)
(Reporter)

Comment 32

14 years ago
Hi,

It looks like the non-standard description is causing some problems, so I guess
it will be better to give it up.
Can you please update to the description below (I believe the DB allows one
break between the two parts) :

****************************************************************
Do you listen to Music while surfing the Web?
Now you can control your favorite media player without ever leaving the browser
and more...
<BR>
Supports WinAmp, iTunes, foobar2000, Windows Media Player, Musicmatch,
Quintessential, J. River, jetAudio, MediaMonkey, Media Player Classic, Sonique,
wxMusik, Real Player, XMMS, Noatun, Juk, Amarok, Music Player Daemon, Rhythmbox
and many other players. 
****************************************************************

Thanks,
Alex
Assignee: psychoticwolf → jedsbugs
Status: REOPENED → NEW

Comment 33

14 years ago
Done :)

@Giorgio Maone:
Probably because each entry is a different version. This extension gets updated
pretty often )
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
Bulk Moving Extension/Theme listing bugs to new component.
(Filter: masslistingspam)
Component: Update → Listings
Product: mozilla.org → Update
Version: other → unspecified
(Reporter)

Comment 35

14 years ago
Hi,

Please update the FoxyTunes entry as compatible with Thunderbird 1.0 and Mozilla
Suite 1.8.

I've already updated my update script.

Thanks,
Alex
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

14 years ago
Assignee: jedsbugs → Bugzilla-alanjstrBugs
Status: REOPENED → NEW

Comment 36

14 years ago
Reassigning to Wolf to manually edit the DB.
Assignee: Bugzilla-alanjstrBugs → psychoticwolf

Updated

14 years ago
Assignee: psychoticwolf → nobody

Updated

14 years ago
Whiteboard: Requires DB edit

Comment 37

14 years ago
The good news is that this no longer requires a manual DB edit.
Whiteboard: Requires DB edit

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 38

14 years ago
Thanks for adding the 1.1 version :)

The description got partially erased (the *version*/second part?), it should be:
****************************************************************
Do you listen to Music while surfing the Web?
Now you can control your favorite media player without ever leaving the browser
and more...
<BR>
Supports WinAmp, iTunes, foobar2000, Windows Media Player, Musicmatch,
Quintessential, J. River, jetAudio, XMPlay, MediaMonkey, Media Player Classic,
Sonique, wxMusik, Real Player, XMMS, Noatun, Juk, Amarok, Music Player Daemon,
Rhythmbox and many other players.
****************************************************************
I believe that without this desciption many users won't understand what
FoxyTunes does, and thus it is very important.

Thanks in advance :)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 39

14 years ago
I think the picture helps.

The good news is that it has the line break in
https://addons.update.mozilla.org/extensions/showlist.php?application=firefox&version=1.0&os=Windows&numpg=50&pageid=2

The bad news is that it keeps eating the html tag, so
https://addons.update.mozilla.org/extensions/moreinfo.php?application=firefox&version=1.0&os=Windows&numpg=50&id=219
doesn't have the break and there's nothing I can do about it.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.