[Linux] Bookmarks export fails

VERIFIED DUPLICATE of bug 241987

Status

()

Firefox
Bookmarks & History
--
major
VERIFIED DUPLICATE of bug 241987
14 years ago
12 years ago

People

(Reporter: Angelo, Assigned: vlad)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: similar problem: bug 255069)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040811 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040811 Firefox/0.9.1+

Exporting bookmarks fails with the file not created and bookmarks are frozen
(can't delete or add any other)

Reproducible: Always
Steps to Reproduce:
1. Try Export the bookmarks
Actual Results:  
No file created and bookmarks messed up

Expected Results:  
All works good :)
(Reporter)

Comment 1

14 years ago
frozen bookmarks is not always reproducible, it happened to me only the first
time, with 08/13 branch still export fails but no bookmarks messed up
Summary: [Linux] Bookmarks export fails and bookmarks are frozen → [Linux] Bookmarks export fails

Comment 2

14 years ago
I can reproduce this with a similar build.

The js console shows this error:
Error: [Exception... "Component returned failure code: 0x80520012
(NS_ERROR_FILE_NOT_FOUND) [nsIRDFDataSource.DoCommand]"  nsresult: "0x80520012
(NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://browser/content/bookmarks/bookmarks.js :: anonymous :: line 361"  data: no]
Source File: chrome://browser/content/bookmarks/bookmarks.js
Line: 361

That's in doBookmarksCommand(), this line:
BMDS.DoCommand(sourcesArray, rCommand, argsArray);

This is a similar problem as bug 255069, although that one's about exporting to
a non-default name. But I can't even export using the default name.
-> confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0?
Whiteboard: similar problem: bug 255069

Comment 3

14 years ago
This is a dupe of bug 241987.  The workaround is that if you touch bookmark.html
(or whatever) before exporting then you will be prompted to overwrite, then it
will work.  The file just has to exist before exporting due to a bug in
bookmarks.js.

Comment 4

14 years ago
It is possible to apply the patch from bug 241987 on Linux yourself.  You need
to have the Java sdk installed.  First get rid of fastjar and replace it with
the jar from the java kit.  fastjar is buggy code. The procedure I found was:

cd /tmp
cp /usr/local/mozilla/chrome/comm.jar .
jar xvf comm.jar
Error! CRCs do not match! Got 5e52bf8, expected 6e16769
delete /usr/bin/fastjar and replace with a link to  /usr/java/j2sdk1.4.1_01/bin/jar
jar xvf comm.jar
mv comm.jar comm.orig
cd content/communicator/bookmarks/
cp bookmarks.js /tmp/bookmarks.orig
patch bookmarks.js patchfile   -- or just edit
cd /tmp
jar cv0f comm.jar content
cp comm.jar /usr/local/mozilla/chrome/

restart mozilla - try exporting a new bookmark file - Worked!

Comment 5

14 years ago
Dang.  Previous comment was mozilla instructions. Always proofread.  Corrected
instructions assuming you unstalled in /opt/firefox are:

cd /tmp
cp /opt/firefox/chrome/browser.jar .
jar xvf browser.jar
mv browser.jar browser.orig
cd content/browser/bookmarks/
cp bookmarks.js /tmp/bookmarks.orig
patch bookmarks.js patchfile   -- or just edit
cd /tmp
jar cv0f browser.jar content
cp browser.jar /opt/firefox/chrome/

The strange thing is that this patch appears to be there already in:
  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Did it get removed or lost?

Comment 6

14 years ago
I have same problem on WinMe with 2004-09-01-0.9.
Mozilla/5.0 (Windows; U; Win 9x 4.90; ja-JP; rv:1.7.3) Gecko/20040901
Firefox/1.0 PR (NOT FINAL)


When export them to no-exist file, I got an error message
in JS console:
> Error: [Exception... "Component returned failure code: 0x80520012
(NS_ERROR_FILE_NOT_FOUND) [nsIRDFDataSource.DoCommand]"  nsresult: "0x80520012
(NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://browser/content/bookmarks/bookmarks.js :: anonymous :: line 368"  data: no]
> Source File: chrome://browser/content/bookmarks/bookmarks.js
> Line: 368


And I made an empty file named 'bookmarks.html' and
overwrite it, exporting bookmarks successfully finished.

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 241987 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED

Updated

14 years ago
Flags: blocking-aviary1.0?
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.