search plugins cannot be reordered

RESOLVED FIXED in Firefox 2 alpha2

Status

()

P1
enhancement
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: justincwatt, Assigned: Gavin)

Tracking

({fixed1.8.1})

unspecified
Firefox 2 alpha2
fixed1.8.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [swag: 0d (work in bug 232272)])

(Reporter)

Description

14 years ago
the order of search plugins in the search menu/toolbar are not alphabetically
reordered after installing a search plugin or after restarting firefox, contrary
to bug 225717. 

bug 255543 proposes a search toolbar context menu option to alphabetically order
the plugins manually.

however, there should be a mechanism to manually reorder the items using the
mouse similar to the method used for reordering bookmarks in the bookmarks menu.

in fact i would go so far as to say that search plugins are just special
bookmarks and should be managed via the bookmark manager

Updated

14 years ago
OS: Windows 2000 → All

Comment 1

14 years ago
I'd prefer to have them draggable from the menu, if possible.

Comment 2

14 years ago
I think that this bug is included in bug 232272

Comment 3

13 years ago
as mentioned earlier, this is a duplicate of another bug report, refer to <a
href="https://bugzilla.mozilla.org/show_bug.cgi?id=225717">bug 225717</a> for my
temporary hack.
Depends on: 317107
Assignee: p_ch → gavin.sharp
Hardware: PC → All
Target Milestone: --- → Firefox 2 alpha2
Status: NEW → ASSIGNED
Depends on: 232272
Priority: -- → P2
Whiteboard: [swag: 0d (work in bug 232272)]

Updated

13 years ago
Flags: blocking-firefox2+
Priority: P2 → P1
Fixed in bug 232272. See also bug 335086.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.