"<!" get partially removed from before the CDATA Tags in the XML document

RESOLVED DUPLICATE of bug 105937

Status

()

RESOLVED DUPLICATE of bug 105937
14 years ago
13 years ago

People

(Reporter: priit, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.8

Well i'm not sure if this goes through, because it's in textaree and I'm filing
this wirh textarea ...

Following is valid xml with entity definition:
<!DOCTYPE html SYSTEM "template.dtd" [
<!ENTITY node "<![CDATA[<img src='node.jpg'>]]>">
<!ENTITY node2 "<![CDATA[<img src='node2.jpg'>]]>">
]>
<html>
</html>

when I read this from file using my CMS all the <! from the beginning of ENTITY
gets lost and I see:
<!DOCTYPE html SYSTEM "template.dtd" [
ENTITY node "<![CDATA[<img src='node.jpg'>]]>">
ENTITY node2 "<![CDATA[<img src='node2.jpg'>]]>">
]>
<html>
</html>

although View Source show's that the <! is there, but not displayed. When I
submit the form I receive exactly what I see, <!'s are gone.

If I submit that again, next <! get's lost:

<!DOCTYPE html SYSTEM "template.dtd" [
ENTITY node "[CDATA[<img src='node.jpg'>]]>">
ENTITY node "[CDATA[<img src='node2.jpg'>]]>">
]>
<html>
</html>

Teasted also on NN3.04, IE5.0 and Safari 1.2, all of them performed as
excpected, no loss ox <!. 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
the problem is still present in

Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

Comment 2

14 years ago
Experienced the same problem.
This works fine in other browsers.

Another interesting behaviour here is if you type the following:
&lt;!E  (i used entities here to make sure it doesnt break).

What happens is that it reads &lt;! followed by any sign as a commentstart and
thus breaks the entire page where you do this.
At first i thought it had problems with < followed by !.
But the following works perfectly fine:
<!a> or <!> or <!

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
Created attachment 187800 [details]
DTD keywords render incorrectly in a loaded textarea

The same problem occurs when loading the ATTLIST dtd keyword into a textarea.
(Firefox 1.0.4, WinXP SP2, PC)
(In reply to comment #3)
> Created an attachment (id=187800) [edit]
> DTD keywords render incorrectly in a loaded textarea
> 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050629
Firefox/1.0+ ID:2005062910

I believe the test case is displaying correctly for me.

Ashis could you please test with a current trunk nightly build (
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-1.0+.en-US.win32.installer.exe
)

as firefox 1.0.4 is very out of date (the geko is overa year old)

Comment 5

13 years ago
Cheers Jaime, it wasn't working on my stable release:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511
Firefox/1.0.4

But looks fine in most recent nightly build of Deer Park Alpha 1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050629
Firefox/1.0+
That means that this can probably be closed WFM and will be fixed in the next
firefox release (1.1).

However I am not sure if all the issues mentioned in comment 0 are fixed.

Comment 7

13 years ago
Updating summary to better reflect this bug report and to be followed by 2 more
duplicate bugs soon.

Decided to leave Product as Firefox intact and Component as General intact since
I could not reproduce this bug in SeaMonkey and 2 other bugs are firefox related.
Summary: textarea does not display xml correctly, cannot edit xml in textarea → "<!" get partially removed from before the CDATA Tags in the XML document

Comment 8

13 years ago
*** Bug 265101 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
*** Bug 306605 has been marked as a duplicate of this bug. ***
This looks like a duplicate of bug 105937, which will be fixed in Firefox 1.5.

*** This bug has been marked as a duplicate of 105937 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.