Pref OK button does not always work

VERIFIED DUPLICATE of bug 30801

Status

P2
normal
VERIFIED DUPLICATE of bug 30801
19 years ago
14 years ago

People

(Reporter: moughamian, Assigned: matt)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
1. For any of the topics listed in the Prefs Menu, it takes two to three seconds just for each set of topic options to load (once clicked).
2. The Font Preferences have a major rendering bug of some kind. First, each of the drop-down menus pops in, one by one, at about 15 
pixels wide. Then once they're all in place, they resize (one by one) to their indtended length. Then, when I select one of them, the 
menu itself sometimes will move, displacing the other menus below. This last part is not always repeatable, but the first 
observations are. Tried a re-install of M13, did not help.
3. After changing several prefernce options in various topic areas, the OK button would not work. That is, I could not close the 
Preferences dialog without hitting Cancel - and therefore without losing all of my changes.
4. There should be full e-mail account management from this area - and when in Composer, it should take you to said account 
management area instead of a separate one (which I've posted another bug for: there is no password field).

You guys gotta fix stuff like this by beta or people won't even be willing to try it. I've been one of  Mozilla's biggest evangelists in 
various Apple forums, and I'm going to end up eating crow for recommending M13. Your description says "stable enough for 
everyday use" - I don't think that's true yet given how buggy the preference panels are implemented. This is a very basic thing we're 
talking about he

Comment 1

19 years ago
This is happening on Linux as well with build 2000012909.

In addition, if I go to Fonts and then some other panel like Colors and then go
back to Fonts, the font dropdowns are totally non-functional.  Also, if I go to
the Appearance panel and then to some other panel and back, the checkboxes and
radio buttons will have lost all their settings with nothing selected or
checked.

If I then cancel the dialog, I cannot bring up Preferences again.  Nothing
happens if I try, but if I try, Mozilla hangs when I shut it down, and I have to
kill it.

Comment 2

19 years ago
*** Bug 25557 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
*** Bug 25558 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
*** Bug 25558 has been marked as a duplicate of this bug. ***

Comment 5

19 years ago
(1) is a either a general performance problem, or a dup of bug 24606.
(3) is a dup of bug 24830, as is the first problem described by
stephe@wenet.net.

The other problem that stephe@wenet.net described (can't open Prefs dialog
twice) is bug 25702.

Comment 6

19 years ago
Re-summarized this bug to focus on item number 3 in the original description. 
Please file SEPARATE bugs for the other problems -- one bug per problem, that's
the way it works.  These four issues aren't really related.

Downgraded severity to normal -- this is not a critical bug.

Matt, I can't reproduce this on Linux or Windows.  Do you see this behavior?
Severity: critical → normal
Priority: P3 → P2
Summary: Preferences Panel: 4 problems → Pref OK button does not always work
Target Milestone: M14
h'm, well on winNT i see this problem after fiddling with IM panels --see bug
25964.

then there's bug 24890, which is currently marked as wfm...

pls lemme know if this has anything to do with those two bugs. am just wondering
if we're encountering dups. (and if not, why. :-) thx!

let me know if this is a dup of that one.

Comment 8

19 years ago
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences

Updated

19 years ago
Blocks: 27826

Updated

19 years ago
No longer blocks: 27826
(Assignee)

Comment 9

19 years ago
the reason this happens in because 
a pref that is a sting is
in the prefs.js is a int.  You need to blow
that pref away otherwise we will get a js error.
Need to put error checking code in for this.
Status: NEW → ASSIGNED
(Assignee)

Comment 10

19 years ago

*** This bug has been marked as a duplicate of 30801 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
verif.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.