crash on gzipped file [@ nsFilePicker::Show ]

RESOLVED DUPLICATE of bug 255366

Status

--
critical
RESOLVED DUPLICATE of bug 255366
14 years ago
7 years ago

People

(Reporter: harri, Assigned: caillon)

Tracking

({64bit, crash})

Trunk
x86
Linux
64bit, crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8a3) Gecko/20040813
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8a3) Gecko/20040813

If I click on http://www.kernel.org/pub/linux/kernel/v2.6/patch-2.6.8.1.gz ,
then Mozilla disappears.



Reproducible: Always
Steps to Reproduce:
1.just click on the URL
2.
3.



Expected Results:  
uncompress the gzipped file and display in browser window.

Mozilla has been built using gcc 3.4.1 on Debian.

Comment 1

14 years ago
can you recompile Mozilla with symbols (without --disable-debug) and attach a
stack trace using GDB ?
Start Mozilla with "mozilla -g"
"GDB> run"
when mozilla crashes, type
"GDB> bt" and attach the output (bt: backtrace) on bugzilla 'create a new
attachment'
Severity: normal → critical
Keywords: crash, stackwanted
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040807

Reporter, are you using Debian or Mozilla.org sources?
(Reporter)

Comment 3

14 years ago
Of course I am using the latest snapshot of mozilla.org.

When I click on 'Create a New Attachment', then Mozilla crashes, too. So here is
the backtrace:

(gdb) bt
#0  0x0000002a95b796c5 in raise () from /lib/libpthread.so.0
#1  0x0000002a9afbdd69 in nsProfileLock::FatalSignalHandler (signo=11) at
nsProfileLock.cpp:204
#2  <signal handler called>
#3  0x0000002a95e5c88b in gtk_file_chooser_dialog_get_type () from
/usr/lib/libgtk-x11-2.0.so.0
#4  0x0000003000000020 in ?? ()
#5  0x0000000000000001 in ?? ()
#6  0x0000000000000001 in ?? ()
#7  0x00000000011d2140 in ?? ()
#8  0x0000000000000011 in ?? ()
#9  0x0000007fbfffdb50 in ?? ()
#10 0x0000002a96af3418 in ?? () from /usr/lib/libglib-2.0.so.0
#11 0x0000000000709380 in ?? ()
#12 0x00000000fffffffa in ?? ()
#13 0x0000002a9ad513e8 in gTextUriListType ()
   from
/usr/local/stow/mozilla-1.8.debug/lib/mozilla-1.8a3/components/libwidget_gtk2.so
#14 0x0000000000000000 in ?? ()
#15 0x000000000056e180 in ?? ()
#16 0x0000002a968e07e8 in ?? () from /usr/lib/libgobject-2.0.so.0
#17 0x0000000000000010 in ?? ()
#18 0x0000002a968da748 in ?? () from /usr/lib/libgobject-2.0.so.0
#19 0x0000000000709380 in ?? ()
#20 0x0000000000000001 in ?? ()
#21 0x0000002a968a5000 in ?? ()
#22 0x00000000000000a6 in ?? ()
#23 0x0000002a968d39a4 in g_type_check_instance_cast () from
/usr/lib/libgobject-2.0.so.0
#24 0x0000002a9ad3f187 in nsFilePicker::Show (this=0x11d2140,
aReturn=0x7fbfffda10) at nsFilePicker.cpp:404
#25 0x0000002a988d816b in XPTC_InvokeByIndex (that=0x11d2140, methodIndex=17,
paramCount=1, params=0x7fbfffda10)
    at xptcinvoke_x86_64_linux.cpp:209
#26 0x0000002a98be1770 in XPCWrappedNative::CallMethod (ccx=@0x7fbfffdb50,
mode=XPCWrappedNative::CALL_METHOD)
    at xpcwrappednative.cpp:2027
#27 0x0000002a98be9941 in XPC_WN_CallMethod (cx=0x7aa820, obj=0x87e030, argc=0,
argv=0x7fbfffdb50, vp=0x7fbfffdd10)
    at xpcwrappednativejsops.cpp:1287
#28 0x0000002a956b30b0 in js_Invoke (cx=0x7aa820, argc=0, flags=0) at
jsinterp.c:1281
#29 0x0000002a956bf7d2 in js_Interpret (cx=0x7aa820, result=0x7fbfffe038) at
jsinterp.c:3375
#30 0x0000002a956b3112 in js_Invoke (cx=0x7aa820, argc=4, flags=2) at
jsinterp.c:1301
#31 0x0000002a98bdb951 in nsXPCWrappedJSClass::CallMethod (this=0x11db5d0,
wrapper=0x7fbfffe2c0, methodIndex=4, 
    info=0x11d8280, nativeParams=0x7fbfffe5b0) at xpcwrappedjsclass.cpp:1336
#32 0x0000002a98bd5eb8 in nsXPCWrappedJS::CallMethod (this=0x11d4f20,
methodIndex=4, info=0x11d8280, 
    params=0x7fbfffe5b0) at xpcwrappedjs.cpp:449
#33 0x0000002a988d860f in PrepareAndDispatch (self=0x11d4f20, methodIndex=4,
args=0x7fbfffea50, 
    gpregs=0x7fbfffe670, fpregs=0x7fbfffe6a0) at xptcstubs_x86_64_linux.cpp:156
#34 0x0000002a988d86ab in SharedStub () at xptcstubs_x86_64_linux.cpp:164
#35 0x0000002a9be7af60 in nsExternalAppHandler::PromptForSaveToFile
(this=0x11b1060, aNewFile=0x7fbfffea50, 
    aDefaultFile=@0x11b10c8, aFileExtension=@0x7fbfffe908) at
nsExternalHelperAppService.cpp:1941
#36 0x0000002a9be7b3b6 in nsExternalAppHandler::SaveToDisk (this=0x11b1060,
aNewFileLocation=0x7fbfffe8d0, 
    aRememberThisPreference=1) at nsExternalHelperAppService.cpp:2028
#37 0x0000002a9be79e95 in nsExternalAppHandler::OnStartRequest (this=0x11b1060,
request=0x7fbfffec40, aCtxt=0x1)
    at nsExternalHelperAppService.cpp:1545
#38 0x0000002a9be6e87a in nsDocumentOpenInfo::OnStartRequest (this=0x103bb90,
request=0x103b650, aCtxt=0x0)
    at nsURILoader.cpp:326
#39 0x0000002a994b5d65 in nsHttpChannel::CallOnStartRequest (this=0x103b650) at
nsHttpChannel.cpp:668
#40 0x0000002a994b62a8 in nsHttpChannel::ProcessNormal (this=0x103b650) at
nsHttpChannel.cpp:828
#41 0x0000002a994b5f2a in nsHttpChannel::ProcessResponse (this=0x103b650) at
nsHttpChannel.cpp:712
#42 0x0000002a994bdf0f in nsHttpChannel::OnStartRequest (this=0x103b650,
request=0x1050fb0, ctxt=0x1)
    at nsHttpChannel.cpp:3543
#43 0x0000002a9942a723 in nsInputStreamPump::OnStateStart (this=0x1050fb0) at
nsInputStreamPump.cpp:379
#44 0x0000002a9942a60c in nsInputStreamPump::OnInputStreamReady (this=0x1050fb0,
stream=0xee67c0)
    at nsInputStreamPump.cpp:335
#45 0x0000002a9889a507 in nsInputStreamReadyEvent::EventHandler
(plevent=0x11b9590) at nsStreamUtils.cpp:118
#46 0x0000002a988b5094 in PL_HandleEvent (self=0x1052858) at plevent.c:692
#47 0x0000002a988b4fae in PL_ProcessPendingEvents (self=0x61b200) at plevent.c:627
#48 0x0000002a988b747b in nsEventQueueImpl::ProcessPendingEvents (this=0x6295c0)
at nsEventQueue.cpp:391
#49 0x0000002a9ad331d2 in event_processor_callback (source=0x11b9590,
condition=15624128, data=0x1)
    at nsAppShell.cpp:67
#50 0x0000002a96b1373d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#51 0x0000002a96b15417 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#52 0x0000002a96b157b5 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#53 0x0000002a95ea7a11 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#54 0x0000002a9ad33679 in nsAppShell::Run (this=0x6c39c0) at nsAppShell.cpp:142
#55 0x0000002a9a73ffcc in nsAppShellService::Run (this=0x11b9590) at
nsAppShellService.cpp:488
#56 0x000000000041e6da in main1 (argc=2, argv=0x7fbffff4b8, nativeApp=0x11b9590)
at nsAppRunner.cpp:1321
#57 0x000000000041f194 in main (argc=2, argv=0x7fbffff4b8) at nsAppRunner.cpp:1798
(Reporter)

Comment 4

14 years ago
PS: More precisely: Mozilla crashes when I click on the [Browse...] button.

Comment 5

14 years ago
can you mention the about:buildconfig output to see what flags were used to
compile Mozilla on x86_64 ?
Keywords: stackwanted → 64bit
Summary: crash on gzipped file → crash on gzipped file [@ nsFilePicker::Show ]
(Reporter)

Comment 6

14 years ago
Build platform
target
x86_64-unknown-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.4.1 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align
-Wno-long-long -pedantic -pthread -pipe
c++ 	gcc version 3.4.1 	-fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -pedantic -fshort-wchar -pthread -pipe
-I/usr/X11R6/include

Configure arguments
--prefix=/usr/local/stow/mozilla-1.8 --enable-default-toolkit=gtk2 --enable-crypto 
This is probably my fault.  I'll look into it.
Assignee: general → caillon

Comment 8

14 years ago
These stacks look the same, marking as duplicate.  caillon, I'll assign bug
255366 to you as you took this one.  Feel free to un-assign if you wish :)

*** This bug has been marked as a duplicate of 255366 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Crash Signature: [@ nsFilePicker::Show ]
You need to log in before you can comment on or make changes to this bug.