Bring back clear button for 3pane quick search box (or use Esc key to clear)

RESOLVED DUPLICATE of bug 262008

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 262008
14 years ago
6 years ago

People

(Reporter: Lorenzo Colitti, Assigned: Lorenzo Colitti)

Tracking

unspecified
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
Please bring back the clear button for the quick search box in the 3pane window.
It is badly missed (at least by me) and a typical mail window does not need the
extra space.

Other search fields don't have a clear button because they require some action
to activate the search. The quick search needs a clear button because changes
apply to the thread pane instantly. The clear button is great because it
"dismisses the search" but still leaves the search result visible in the thread
pane so you can work on it.

Typical usage is that you type in the search field to make the message you are
looking for visible in the thread pane. Then you click on the message to read,
reply, or whatever. Then you click clear (because you're probably going to
scroll back to the top of the folder). The absence of the clear button turns a
click into a click+drag+keypress, which is annoying.
(Assignee)

Comment 1

14 years ago
Or maybe a we could be consistent with Firefox and clear the search bar if the
user presses ESC?

Comment 2

14 years ago
I'd be happy with a  patch that made escape clear it like firefox. 
(Assignee)

Comment 3

14 years ago
Created attachment 156143 [details] [diff] [review]
patch v1

This patch clears the search bar when escape is pressed.

Unfortunately, escape is also used for the Stop command. For now the patch does
both, but what do we want to do about this?

I don't know why, but when the search box is cleared it "flickers". For this
reason the patch calls onClearSearch() only if there is nothing in the textbox.
But the problem is probably due to the search bar itself. I'll look into it
some more.
tentatively nominating for aviary1.0, as there's a patch...
Flags: blocking-aviary1.0?
Summary: Bring back clear button for 3pane quick search box → Bring back clear button for 3pane quick search box (or use Esc key to clear)
(Assignee)

Comment 5

14 years ago
If ESC clears the quick search bar, it would make sense for it to reset the
message view to "All" as well.

I think it is reasonable for ESC to perform this action instead of Stop. Scott,
as Thunderbird "application czar", what do you think?
Assignee: mscott → lorenzo

Comment 6

13 years ago
i think a lot of people liked the way it worked before with the button (of
course i could be completely wrong).  it would be nice to have the new added
functionality but with the button.  perhaps the button could be an option
similar to the "go" button in firefox.

can it be moved back to the left side too? :)

Comment 7

13 years ago
(In reply to comment #3)
> Unfortunately, escape is also used for the Stop command. For now the patch
> does both, but what do we want to do about this?

What does Firefox do?


(In reply to comment #5)
> If ESC clears the quick search bar, it would make sense for it to reset the
> message view to "All" as well.

Not necessarily; for instance, someone might have People I Know selected as a 
view, and be trying different strings to match on Subject in an attempt to 
locate a particular, not-well-remembered message.  That user would be peeved 
about having to reset the view every time.  (But, see bug 237165.)

Comment 8

13 years ago
*** Bug 260115 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
xref bug 243307 comment 1.

Comment 10

13 years ago
My humble vote to bring the button back by completely agreeing with the original
reporter of this bug.  I miss the button every day!

I didn't know that ESC clears the search in Firefox until now which means it's
not intuitive.  The behavior in Thunderbird is slightly different because search
is instant and is used as a "filter" rather than as "search".  Also, Thunderbird
has considerably more real estate in this spot.

Comment 11

13 years ago
When the Clear button is brought back, it should retain its ability to respond
to Alt-C.

Comment 12

13 years ago
Someone wrote an extension for a clear button.  See
http://update.mozilla.org/extensions/moreinfo.php?id=259&vid=782

I agree though.  I liked having the clear button by default.

Comment 13

13 years ago
trying to shut down changes to features.  hope the extension works for folks for
the 1.0 release.
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 14

13 years ago
Ben suggested a neat way to do this. I'm tracking that in a different bug. 

*** This bug has been marked as a duplicate of 262008 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 15

13 years ago
*** Bug 262342 has been marked as a duplicate of this bug. ***

Comment 16

13 years ago
*** Bug 262380 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.