Browser consumes 100% of CPU

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
6 months ago

People

(Reporter: braden, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
The browser consumes 100% of the CPU--indefinitely--upon loading
<http://www.freedrinkingwater.com>.

Comment 2

15 years ago
confirmed with linux trunk 20040814
==> layout/images
Assignee: general → jdunn
Component: Browser-General → Layout: Images
Keywords: topperf → testcase
QA Contact: general → core.layout.images
Version: 1.7 Branch → Trunk
Created attachment 176280 [details]
testcase2

The first testcase takes for me only 100% cpu when it is in a background tab.

This testcase also takes 100% cpu when it is in a foreground tab. Removing the
"GIF89a" makes the 100% cpu go away. 
After pressing "Stop" the 100% cpu goes away.

Comment 4

14 years ago
Is this also a JavaScript error?

Bug apparently blocks JavaScript from executing.  A moving banner at the bottom
of the Web page is not displayed.

Bug goes away in Mozilla 1.7.5 or Fx 1.0.1 if you disable allowing JS to move
images (Edit/Preferences/Advanced/Scripts & Plug-ins/Allow scripts to Change
images in Mozilla 1.7.5).  (This option may not be available in recent trunk
builds).

OS should probably be marked as "All".  Bug occurs in Win 98 and XP.
OS: Linux → All

Comment 5

13 years ago
(In reply to comment #3)
> Created an attachment (id=176280) [edit]
> testcase2
> 
> The first testcase takes for me only 100% cpu when it is in a background tab.
> 
> This testcase also takes 100% cpu when it is in a foreground tab. Removing the
> "GIF89a" makes the 100% cpu go away. 
> After pressing "Stop" the 100% cpu goes away.

WFM, no rise in the CPU load at all

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060504 Minefield/3.0a1
I'm still seeing this bug with current trunk build.
But I'm beginning to think this is not a bug at all in Mozilla, this is exactly what should happen. The scripts used in the testcases and the url are creating an endless loop.

Comment 7

11 years ago
WFM, no rise in the CPU load at all

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14 

Comment 8

10 years ago
URL WFM, but that first testcase hogs my CPU more than http://www.ut3.de/forum/unreal-tournament/unreal-tournament-files/466-jessica-1-5/

Terrible perf with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 on 2.6 GHz Windows XP, 1 GB RAM, Radeon 9800.

Comment 9

10 years ago
(In reply to comment #8)
> URL WFM, but that first testcase hogs my CPU more than
> http://www.ut3.de/forum/unreal-tournament/unreal-tournament-files/466-jessica-1-5/
> 
> Terrible perf with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4)
> Gecko/20090423 Firefox/3.5b4 on 2.6 GHz Windows XP, 1 GB RAM, Radeon 9800.

Yes, but that's Bug 361754, not relevant for this bug.
testcase 2 WFM with current trunk + vista
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

6 months ago
Product: Core → Core Graveyard

Updated

6 months ago
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.