Closed Bug 255747 Opened 16 years ago Closed 8 years ago

Thunderbird RSS Reader loads XHTML pages into XML Parser

Categories

(MailNews Core :: Feed Reader, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bc, Unassigned)

References

()

Details

Sam Ruby's recent post to his blog contained a link to
<http://www.intertwingly.net/blog/2004/08/14/DevCon-5>. This is an XHTML page
containing a &nbsp; entity. Thunderbird loaded this into the XML parser which
due to bug 204102 causes Thunderbird to complain about the undefined entity.
I can reproduce this on Windows XP, although I'm not entirely sure it's a dupe
of bug 204102 since I can't find a 'standalone-"no"' in the source code for the
attached feed.

bc, could you elaborate on why you feel it's related to bug 204102, other than
the similar error message? I'm probably just missing something. Thanks.
This bug is really about the fact that when you click on the item it attempts to
send the loaded XHTML page through the XML parser. bug 204102 shows its ugly
head because the document when loaded into the XML parser should have been
treated as standalone="no" and the external entities ignored. standalone="no" is
not required to appear in the source code.

From <http://www.w3.org/TR/2003/PER-xml-20031030/#sec-rmd>
<quote>
If there are no external markup declarations, the standalone document
declaration has no meaning. If there are external markup declarations but there
is no standalone document declaration, the value "no" is assumed.
</quote>
I am having a very similar problem with my mathml pages, due to the fact that
thunderbird loads xhtml+mathml page into xml parser. Besides the problem that it
doesn't recognize &nbsp;, it doesn't recognize mathml tags either. The same page
can be correctly rendered in firefox 1.0. Here's my page heading lines:

<?xml version="1.0"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1 plus MathML 2.0//EN"
               "http://www.w3.org/TR/MathML2/dtd/xhtml-math11-f.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"
xmlns:math="http://www.w3.org/1998/Math/MathML">

I am not sure if I should submit a separated bug report for my problem. Seems to
me it's related to this bug, so I'll just wait to see I can get a response
within this bug.(In reply to comment #0)
> Sam Ruby's recent post to his blog contained a link to
> <http://www.intertwingly.net/blog/2004/08/14/DevCon-5>. This is an XHTML page
> containing a &nbsp; entity. Thunderbird loaded this into the XML parser which
> due to bug 204102 causes Thunderbird to complain about the undefined entity.
This bug seems to be especially critical in regard to languages other than
English -- for example, the following RSS feed becomes completely unusable if
you load it into Thunderbird (since the XHTML makes use of entities for all
umlauts):

    http://meiert.com/de/releases/get/rss/index.xml

The RSS as well as the XHTML is completely valid, correct me if I'm wrong. I
still wonder that this apparently major bug is distributed with Thunderbird 1.0,
but is there any chance that this gets fixed soon?

(Any other hints are highly appreciated!)
Same bugs there for my websites. 
My pages are sent as application/xhtml+xml and thunderbird doesn't recognize
HTML entities like Firefox.
It's pretty annoying. Isn't a simple patch to do like Firefox for this kind of
mime types?
QA Contact: rss
Assignee: mscott → nobody
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
since the OP url is gone, and this works for me reading feed summary/web page for comment 4, closing.  please reopen with steps to reproduce if it happens in current releases.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.