Organize Hotkeys in task oriented categories

RESOLVED FIXED in Firefox1.5

Status

Firefox Graveyard
Help Documentation
--
minor
RESOLVED FIXED
14 years ago
2 years ago

People

(Reporter: Percy Cabello, Assigned: Jeff Walden (gone starting June 8))

Tracking

Trunk
Firefox1.5

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040813 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040813 Firefox/0.9.1+

Hotkeys list is too long an unorganized and makes it hard to find a useful hotkey.

Reproducible: Always
Steps to Reproduce:
1. Open the hotkeys page in help
2.
3.

Actual Results:  
A long list of hotkeys

Expected Results:  
An organized list of hotkeys
(Reporter)

Comment 1

14 years ago
Created attachment 156263 [details]
proposed organization.
I included hotkeys for the search bar
(Reporter)

Updated

14 years ago
Attachment #156263 - Attachment description: proposed organization → proposed organization. I included hotkeys for the search bar

Comment 2

14 years ago
Confirming bug. Lets do this after 1.0.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → After Firefox 1.0

Comment 3

14 years ago
Moving to new Firefox Help owner.
Assignee: rlk → jwalden+fxhelp
(Assignee)

Comment 4

13 years ago
This is worth considering for 1.1, particularly as it would just be
reorganization of line groups.
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: Future → Firefox1.1

Comment 5

13 years ago
I'll take a stab at this. A patch will come soon

Comment 6

13 years ago
Created attachment 178620 [details] [diff] [review]
quick patch v1

this is a quick patch I through together. It probably needs some minor editing.
Can some one take a look at it?(Jeff?)

Updated

13 years ago
Attachment #178620 - Flags: review?(jwalden+fxhelp)
(Assignee)

Comment 7

13 years ago
Comment on attachment 178620 [details] [diff] [review]
quick patch v1

The proper way we'll want to split this up is like so (because it's more
semantically valid):

<table border="1" width="100%">
  <thead>
    <tr>
      <th>Command</th>
      <th>&brandShortName;</th>
      <th>Internet Explorer</th>
      <th>Opera</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <th colspan="4">Categorization Foo</th>
    </tr>
    <tr>
      <td>Add Bookmark</td>
      <td>&accelKey;+<kbd>D</kbd></td>
      <td>&accelKey;+<kbd>D</kbd></td>
      <td>&accelKey;+<kbd>T</kbd></td>
    </tr>
    <tr>
      <th colspan="4">Categorization Bar</th>
    </tr>
    <tr>
      <td>Something</td>
      <td>shortcut</td>
      <td>shortcut</td>
      <td>shortcut</td>
    </tr>
  </tbody>
</table>

Beyond that, I need to look at the proposed categorization a bit more first. 
Some of the categorizations are correct and obvious, but some of the ones in
the first attachment seem to be just a bit too general or buzzword-y.  This'll
have to wait a bit until we come up with a definitive list of categories.
Attachment #178620 - Flags: review?(jwalden+fxhelp) → review-
(Assignee)

Comment 8

13 years ago
Created attachment 183010 [details]
Possible org. scheme, feedback wanted

I need feedback here.  I like some of what I've got, but I don't like all of
it.  In particular I very, very much want to avoid having a Miscellaneous
category if at all possible.
Attachment #156263 - Attachment is obsolete: true
Attachment #178620 - Attachment is obsolete: true

Comment 9

13 years ago
>Miscellaneous:
>Complete .com Address
>Complete .net Address
>Complete .org Address
>Delete Selected Autocomplete Entry

Can't the "Complete" turn into Autocomplete?
Then we can move the above into an Autocomplete catagory or soething similar.   


(Assignee)

Comment 10

13 years ago
(In reply to comment #9)
> Can't the "Complete" turn into Autocomplete?
> Then we can move the above into an Autocomplete catagory or soething similar.  

Adding "Auto" seems like a worthwhile change, but at least to me an Autocomplete
category seems a good deal too specific.  This would also make the Misc.
category unusually small, and if we're making a category that small I'd rather
see it removed.  I also can't think of other items with which to augment an
Autocomplete category, and I think a baseline of at least five items per
category is at least a reasonable (tho if need be, breakable) goal.

Also, while I'm thinking about it, we may want to change "Delete Selected
Autocomplete Entry" to something like "Delete Saved Form Entry" (assuming that's
clear enough) because Shift+Del applies to all form elements with saved entries.

Comment 11

13 years ago
"Complete .com Address" etc. just adds e.g. ".com". That has nothing to do with
autocomplete, which offers previously entered information based on the first
characters the user entered.

Shift-Del also works in the location bar and the search bar, and I wouldn't call
these "forms".

I'm not too concerned about the misc category. I'd put Text Size
Increase/Decrease/Restore next to each other. The last proposal looks pretty
good otherwise.

Comment 12

13 years ago
sorry for bug spamming, but for whoever does this bug, try to help fix bug
247595 too.(by using entities)
(Assignee)

Comment 13

13 years ago
Created attachment 183969 [details] [diff] [review]
Rearrange things, more or less as described previously

I moved New Message into the Miscellaneous category.  It wasn't in the previous
list because I made the previous list in Linux, whereas to create the patch I
created the categories and then started moving shortcuts into categories one by
one.  I ended up with New Message, which didn't quite seem tool-like to me and
thus got put in Miscellaneous.

Because things are moved around so much, reading the patch doesn't do a whole
lot of good; applying and testing it are probably the only way to really
evaluate it.

One last: the styling of this table currently looks really horrible.  After
this is fixed I'm going to file a bug to get something better-looking here,
because this bluish color is truly ugly.
Attachment #183969 - Flags: review?(steffen.wilberg)

Comment 14

13 years ago
Comment on attachment 183969 [details] [diff] [review]
Rearrange things, more or less as described previously

Nice! The content, that is. The location of "New Message" as fine as well.

But please do file the bug on improving the style, ugh :)
Attachment #183969 - Flags: review?(steffen.wilberg) → review+
(Assignee)

Updated

13 years ago
Attachment #183969 - Flags: approval-aviary1.1a1?

Updated

13 years ago
Attachment #183969 - Flags: approval-aviary1.1a1? → approval-aviary1.1a1+
(Assignee)

Comment 15

13 years ago
Patch checked in, and bug 295229 filed for the styling issues.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Version: unspecified → Trunk
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.