page in another tab can steal keyboard focus from visible tab

VERIFIED DUPLICATE of bug 124750

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 124750
14 years ago
14 years ago

People

(Reporter: Eric Seppanen, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.8

Some pages have javascript that moves the keyboard focus after the page loads. 
For example, http://www.ebay.com/ places the keyboard focus in their search
input control.

However, this works even if the page is in a tab that's not visible right now. 
If you're typing in the visible tab, your keystrokes suddenly stop appearing and
they're silently redirected to a window you can't see.  Very confusing.

Reproducible: Always
Steps to Reproduce:
1. Load http://www.google.com/
2. Create a new tab, type www.ebay.com.
3. Quickly press enter (to get the browser to fetch the ebay page) then switch
to the google tab and start typing something.
4. When the ebay page finishes loading, you will see that the text you're typing
into the google form suddenly stops appearing.  If you flip to the ebay tab you
will find some of your text has appeared there.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.