If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Leaking nsIFiles in nsDirectoryService::Set()

RESOLVED FIXED in M14

Status

()

Core
XPCOM
P3
normal
RESOLVED FIXED
18 years ago
15 years ago

People

(Reporter: Patrick C. Beard, Assigned: dougt)

Tracking

({mlk})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Leaking nsIFile in nsDirectoryService::Set().

Comment 1

18 years ago
this belongs to dougt.  reassigning to him.
Assignee: ssu → dougt
(Assignee)

Comment 2

18 years ago
good find.  I am going to check this in with other changes to nsDirectoryService
later this week.
Status: NEW → ASSIGNED
Whiteboard: fix in hand.

Updated

18 years ago
Keywords: mlk
Summary: [MLK] Leaking nsIFiles → Leaking nsIFiles
(Assignee)

Updated

18 years ago
Target Milestone: M14

Updated

18 years ago
Whiteboard: fix in hand. → "fixed, reviewed and tested" - dougt
(Assignee)

Comment 3

18 years ago
*** Bug 28439 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

18 years ago
Fixed checked in.,
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
I'm no longer seeing this leak in Purify.

Updated

15 years ago
Summary: Leaking nsIFiles → Leaking nsIFiles in nsDirectoryService::Set()
Whiteboard: "fixed, reviewed and tested" - dougt
You need to log in before you can comment on or make changes to this bug.