If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

checking for 1. 2. 3. in steps to reproduce in comment-guided

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
User Interface
--
minor
RESOLVED FIXED
13 years ago
5 years ago

People

(Reporter: till busch, Assigned: till busch)

Tracking

unspecified
Bugzilla 2.20

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)
Build Identifier: 

the "steps to reproduce" (reproduce_steps) field in create-guided.html.tmpl 
initially contains "1. 2. 3.", each on a line. even if the user leaves the 
field untouched, the numbers will be included in the bug description. 
 
the default comment-guided.txt.tmpl which merges the fields states: 
[%# I can't make TT check for "1.\n2.\n3." so this is not conditional. -%] 
 
i found out it can be don using re's: 
 
[% IF !(form.reproduce_steps.match('^1\.\s+2\.\s+3\.\s+$') || 
form.reproduce_steps.match('^\s+$')) -%] 
Steps to Reproduce: 
[%+ form.reproduce_steps %] 
[% END %] 
 
the second match() (after ||) is optional, it could also be changed to normal 
checking for an empty string. 
 

Reproducible: Didn't try
Steps to Reproduce:
ooooooh. :)   Do you know how to make a patch for this?
Assignee: myk → buti
Status: UNCONFIRMED → NEW
Component: Creating/Changing Bugs → User Interface
Ever confirmed: true
(Assignee)

Comment 2

13 years ago
Created attachment 156331 [details] [diff] [review]
patch (checking for "1. 2. 3." in comment-guided.txt.tmpl)

this one has 2 regexp's, one that checks for "1. 2. 3." and anotherone that
checks for whitespace only.

Updated

13 years ago
Attachment #156331 - Flags: review?(gerv)
Comment on attachment 156331 [details] [diff] [review]
patch (checking for "1. 2. 3." in comment-guided.txt.tmpl)

r=gerv.

Gerv
Attachment #156331 - Flags: review?(gerv) → review+
Checked in. Thanks for fixing this - it really bugged me :-)

Checking in template/en/default/bug/create/comment-guided.txt.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/comment-guided.txt.tmpl,v
 <--  comment-guided.txt.tmpl
new revision: 1.3; previous revision: 1.2
done

Gerv
Status: NEW → RESOLVED
Last Resolved: 13 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.20
Duplicate of this bug: 230066
Duplicate of this bug: 419733
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.