Focus on "enter query" textbox in sidebar should not select contents

RESOLVED WONTFIX

Status

()

Bugzilla
User Interface
RESOLVED WONTFIX
14 years ago
8 years ago

People

(Reporter: Jonathan Wakely, Unassigned)

Tracking

({ue})

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.4) Gecko/20030703
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.4) Gecko/20030703

The "enter query" textbox on the bugzilla sidebar has this attribute:
onfocus="this.setSelectionRange(0,this.value.length)"

This means that the text "enter query" is automatically copied to the clipboard
in X, replacing the previous contents. I find this very annoying.

Reproducible: Always
Steps to Reproduce:
1. Select a bug number with the mouse, so it's copied to clipboard.
2. Click on textbox of bugzilla sidebar and delete contents
3. Paste bug number by middle-clicking mouse

Actual Results:  
Since focusing on the textbox selects its contents, the bug number on the
clipboard is replaced with the text "enter query". When you paste you therefore
put "enter query" back into the box

Expected Results:  
Bug number should be pasted into textbox, so you can hit enter to view the bug.

You can work around this by focusing on the textbox first, deleting the
contents, changing window to the one containing the bug number, copy it, change
back to mozilla, focus on sidebar textbox again, paste - but this is frustrating.

Could the attribute be changed so that when you focus on it the value is
cleared, without affecting the clipboard?
(Reporter)

Comment 1

14 years ago
Is there an obvious workaround for this that I'm missing?

I can't believe this doesn't annoy other users of the sidebar as well.
Hmm, this would only be a problem for people using X on Linux.  Every other
desktop environment doesn't put anything on the clipboard until you use the copy
command, whether it's selected or not.  I was under the impression Mozilla also
behaved this way even on Linux (you have to actually use the copy command, you
can't just select it)...  apparently it doesn't?  Or maybe that's only the gtk
builds or something?
(Reporter)

Comment 3

14 years ago
Yes, I believe this only affects users of X (though possibly on OSs other than
Linux)

This (admittedly old, 1.4) version of mozilla automatically copies the selection
to the clipboard. There is a "clipboard.autocopy" pref, which defaults to true,
and doesn't seem to change the bugzilla sidebar behaviour whether it's true or
not (I'll try to confirm that).
(Reporter)

Comment 4

14 years ago
Setting the clipboard.autocopy pref to false only seems to take effect after a
restart (with mozilla 1.4), but it does work (so the end of comment #3 is wrong)

Setting it to false does prevent clicking on the textbox from copying "enter
query" to the clipboard. Since other X apps still auto-copy to the clipboard
when you select text, I can highlight a bug number in another window (e.g.
terminal running email client) and paste to the textbox this way - but it means
turning off autocopy, which makes mozilla behave differently to most X apps.
(i.e. weaker integration with rest of desktop environment)

As I make a lot of use of autocopy I might just leave it enabled and live with
the sidebar issue (I've put up with it for months already - I guess I can
survive :-)

Updated

13 years ago
QA Contact: mattyt-bugzilla → default-qa

Updated

12 years ago
Assignee: myk → ui
not sure how best to deal with this...  maybe check useragent and don't do the select all if we're on X11? that's probably the safest thing.  Or should we just get rid of the select-on-focus?  Needs comment from a UE person.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ue
Firefox guys say Firefox ifdefs this on Linux, so I guess there's precedent for that.

http://lxr.mozilla.org/seamonkey/source/browser/app/profile/firefox.js#191
(Reporter)

Comment 7

11 years ago
I don't use the sidebar much any longer, so if this doesn't affect anyone else
feel free to close it.

Comment 8

8 years ago
per reporter's comment 7 and because sidebar.cgi is gone in Bugzilla 4.2, and there is no plan to fix it on branches.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.