remote calendar on secure webdav now more broken

RESOLVED DUPLICATE of bug 255903

Status

--
major
RESOLVED DUPLICATE of bug 255903
14 years ago
12 years ago

People

(Reporter: orion2480, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3 StumbleUpon/1.995
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3 StumbleUpon/1.995

This is likely releated to bug 249796.  However, as it is behaving differently
with the latest (Aug 16) build, I thought to create a new report.

I d/l and installed the Aug 16th builds.  This is reproduced in subscribing to a
remote calendar which requires username/password (such as a secure webdav
server, in my case), results in complete freezeup of Sunbird.  No response
what-so-ever.  Must ctrl-alt-del to kill.

Username/password were never asked for.  Never asked to "okay" the certificate
(which is not signed, as it is a homebrew cert).

In the July 1 build, I would get an authentication error, and I could then click
"okay" and continue (just without my remote cal of course.)  That is no logner
the case in Aug 16 build.  It just freezes (if i select my "calendar" tab first,
I see that it is "trying" to d/l the calendar, but never stops trying.)

A temporary fix, suggested in comment 2 of bug 249796 fixed this problem for the
July 1 build, but has no effect on Aug 16th build.  It doesn't matter whether
the fix is applied, behaviour remains the same.

Differences from July 1 bug:
1) Will not produce authentication error
2) Not fixed by workaround in bug 249796 (same behaviour with/without this patch)

This is the same whether I use the win32 zip, or the actuall win32 install.

And yes, I've check, my remote calendar is still up and available.  In fact, you
get the same behaviour whether the file is real or not.

Reproducible: Always
Steps to Reproduce:
1.  Start SB, click on "calendars" tab (this is not essential, but will show
calendar is trying to refresh calendar)
2.  Subscribe to remote calendar (Tools->Subscribe) which is hosted on https. 
Actually, this can reproduced if you subscribe to both an existent or
non-existant calendar on https. (i.e. https://blah.com/blah.ics gives same
behavriour as a legitimate secured webdav calendar file)
3.  Watch, wait, and eventually ctrl-alt-del
Actual Results:  
Sunbird will stop responding.  It appears it is in an loop, waiting for remote
calendar to d/l (since the circular arrow animation is going).  

Expected Results:  
Remote calendar would load, and SB would respond to UI.
(Reporter)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 255903 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 249796 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
This is a literal copy of 255903, so marking as dup of that. It was meant te be
filed once, marking as dup of other bugs messes up with dup counts. sorry for
the spam.

*** This bug has been marked as a duplicate of 255903 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.