object tag is ignored if a flash movie should be shown....

RESOLVED INVALID

Status

--
minor
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Stephan, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040803 Firefox/0.9.3

If you try to use <object> mozilla does not show a flash movie. You have to use
<embed>.

Example html code:
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0"
width="150" height="400" id="Menu" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="Menu.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#bbafef" />
</object>

Reproducible: Always
Steps to Reproduce:
1.Go to some page with flash but without embed tag

Actual Results:  
No flash movie is shown although the plugin is installed

Expected Results:  
Show the movie

Comment 1

14 years ago
classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"

This is a call to ActiveX.  Since Mozilla doesn't support ActiveX, the OBJECT is
ignored.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.