If Download Manager doesn't start downloading a selection, program stops working.

RESOLVED DUPLICATE of bug 255953

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 255953
13 years ago
9 years ago

People

(Reporter: Don, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; (R1 1.5); .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 windows:U;win98se;en-us;rv1.7

When I make a selection to download say a movie clip.  The Download Manager 
(DM) will display and list all info about the download.  The problem then shows 
up when the download selection does not start to download or stops downloading. 
If I press the pause. I am asked to retry or remove.  If I press retry nothing 
happens.  If I press remove then the Download Manager closes.  Now if I try to 
redownload the same selection, nothing happens.   Now If I try to open a 
different link all that I get is a blank screen w/loading in the left tab. I 
have to exit out of Firefox.  But on the first attempt to open the home page 
upon restarting Firefox.  A blank screen displays, tab shows loading, lower 
left of tab screen shows the URL, and the loading bar shows nothing happening. 
So it is exit out again. This time when I start Firefox my home page loads. An 
runs fine until the Download Manager should not start or stops downloading.  
Note when this happens w/DM if I right click on the selection clip and select 
Net Transport to download the clip it does so w/out any problems.  But I still 
am unable to get Firefox to work. W/out restarting two times.  If I exit 
straight out of Firefox when the download problem appears.  I still have to 
restart two times before Firefox starts working again.

Reproducible: Always
Steps to Reproduce:
1.Find something to download w/DM
2.If DM does not start downloading or stops.
3.Press Pause.
4.Press Retry.
5.Nothing Happens.
6.Press Pause.
7.Press Remove.

Actual Results:  
Never know when a doanload will start or stop.  If it doesnt start then only 
option is to shutdown Firefox and restart. Unkown why it takes two try's to get 
Firefox started. Note if I go back and try to reload the clip the same thing 
happens again.  Note that the back button will go back but still cannot open a 
new URL from there either.

Expected Results:  
I though that when I pressed the remove option that the download was cancelled 
and that the program would continue to operate. I should be able to leave the 
URL that had caused the DM to stall or stop working.  

When the lockout happens. If I go the the same site w/IE I can download the 
clip w/no problems.  If the clip should hang in IE just close the site and can 
continue on w/no lockout.  I have 384M fo ram and while Firefox is running the 
free ram runs between 250 and 202.

Thank you for your time and consideration.
Don

Comment 1

13 years ago
Please resolve this bug as DUPLICATE of your other bug 255953.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 255953 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.