Mozilla Popup Blocker can be fooled with setTimeout if the page is displayed in an frame

VERIFIED DUPLICATE of bug 187255

Status

()

Core
JavaScript Engine
--
major
VERIFIED DUPLICATE of bug 187255
13 years ago
13 years ago

People

(Reporter: Manuel Reimer, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.7.2) Gecko/20040803

The Website at the above URL uses the following JavaScript to display the Popup:

http://javascript.internet.com/navigation/delayed-popup.html

This scripts uses "setTimeout" to call the popup-function after a few seconds.
If a page using this code is displayed in an frame, then Mozilla Popup Blocker
doesn't recognize this as unwanted popup window and so the window gets
displayed. This can even be used to display more than one Popup.

Reproducible: Always
Steps to Reproduce:
1. Enable Popup Blocker
2. Go to the above URL

Actual Results:  
A popup Window gets displayed

Expected Results:  
Popup Blocker should prevent the popup from getting displayed
Works for me with build 2004-08-17-09, Windows XP.

When I loaded the page, 2 seconds later I got a "!" in the lower right of my
Mozilla build showing me it had blocked the popup.

Comment 2

13 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040817
Firefox/0.9.1+
see bug 187255 comment 1

*** This bug has been marked as a duplicate of 187255 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.