file://///server/share/file does not work as hyperlink or source in iframes

RESOLVED DUPLICATE of bug 122022

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 122022
13 years ago
13 years ago

People

(Reporter: Patrick Reinhart, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefohyx/0.9.3

when using a sourcelocation from a samba or windows file share like follows:

\\server\share\file 

in the url form as follows:

file://///server/share/file

it does work when using it in the url field but it wont work in a html document
using the following tags:

<a href="file://///server/share/file.gif">my image file</a>

<iframe src="file://///server/share/file.gif" name="myframe">iframes not
supported</iframe>

<img src="file://///server/share/file.gif">

Reproducible: Always
Steps to Reproduce:
1. create a html file containing a hyperlink, iframe, imgage source
2. open it in browser
3. try to open link

Actual Results:  
1. nothing happens when you click on the link
2. image is not displayed
3. iframe is empty

Expected Results:  
1. link should open the image
2. image itself should be displayed
3. image shoult be displayed in the iframe

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 122022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.