Closed Bug 255997 Opened 18 years ago Closed 18 years ago

Using Taskbar's Address Bar to launch browser produces double windows.

Categories

(Firefox :: Shell Integration, defect)

x86
Windows Server 2003
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 246078

People

(Reporter: arwing2000, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

When Firefox is set as the default browser, using the 'Address Bar' that can be
added to the Windows Taskbar causes two new windows to open when a URL is
entered in to it instead of one. Both display the correct requested website.
I have tested the bug on Windows Server 2003 and XP Pro SP2 on seperate machines.
The Server 2k3 machine also opens an error message box that reads:

Windows can not find 'http://www.google.com'. Make sure you have typed the name
correctly, and then try again. To search for a file, click the Start button, and
then click Search.

The Windows XP machine however does not display this error, it just launches two
copies of Firefox with both displaying the requested web page.

Additional: Testing the problem on other user accounts on the Server 2K3 machine
produced diffrent results. The two main accounts in which Firefox is used 'Nocu'
and 'Naki' both displayed the error message box. The main 'Administrator'
account, which is rearly used, just performed the same as the XP machine,
launching two copies of the browser, but no error.

Reproducible: Always
Steps to Reproduce:
1. Ensure Firefox is the default system browser.
2. Right click a blank area of the Windows Taskbar.
3. Point to Toolbars.
4. Click Address.
5. If needed, 'Unlock the Taskbar' using the same right click menu and then drag
the address bar till it is clearly visible on the taskbar.
6. Type an address of any website in to the Address Bar, then press enter or
click the Go button.
Actual Results:  
Two new Firefox windows opened, both containing the website requested.
Additionaly, under Windows Server 2K3, an error message box saying the URL could
not be found appears.

Expected Results:  
Launch one copy of Firefox, displaying the requested website.

Windows 2k3 machine:

Athlon 3200+
512MB RAM
3 HD's, 80GB (on which Firefox is installed), 2 x 120GB.

Windows XP machine:
Intel P4 2.66Ghz
504MB RAM
1HD, 30GB

*** This bug has been marked as a duplicate of 246078 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.