Caret of input and textboxes invisible due to z-index

RESOLVED DUPLICATE of bug 167801

Status

()

defect
RESOLVED DUPLICATE of bug 167801
15 years ago
6 years ago

People

(Reporter: thom.t, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nb-NO; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nb-NO; rv:1.7) Gecko/20040803 Firefox/0.9.3

In the page, refered at the URL provided, the text caret is hidden by the
underlying div. This happend even though the div containing the input elements
have a higher z-index than the underlying div element.
Seen in Firefox 0.9.3 and Mozilla 1.7.2.

Reproducible: Always
Steps to Reproduce:
1. Assign a fixed position to a div using CSS
2. Give the div a z-index of 0
3. Make another div element with some child input elements
4. Give this div element a higher z-index and a position of "relative or
absolute" (in order for the z-index to have any effect)
Actual Results:  
The input elements (and textarea) does not display any caret.

Expected Results:  
Display the caret.
This is already filed...
Whiteboard: DUPEME

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 167801 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE

Updated

6 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.