Some of the input boxes on the form no longer line up correctly

RESOLVED DUPLICATE of bug 47793

Status

()

RESOLVED DUPLICATE of bug 47793
15 years ago
15 years ago

People

(Reporter: DrSFG, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040817

This is a medical form to report services being provided to a patient. It looks
like a grid of boxes in columns side by side. In all previous builds, these
boxes lined up correctly. Now, a set of them are large and further spaced apart
than others so that the boxes corresponding to a single line item do not line up
correctly.

Reproducible: Always
Steps to Reproduce:
1.Load the page
2.
3.

Actual Results:  
The boxes for entering data do not line up correctly.

Expected Results:  
The boxes should all be the same size and spaced equally apart.

This did not happen in any previous release (even the 1.8a version just prior to
this release.
I've changed the url testcase to the page that should show the bug. 

Comment 2

15 years ago
Created attachment 156471 [details]
screenshot of trunk build of Camino 2004081723

Comment 3

15 years ago
Created attachment 156472 [details]
aviary branch build of FF 20040818

Compared with aviary, the text field of a right-hand side column is not
correctly displayed by tunk.

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
The change on trunk was that the bottom margin of <h2> kids of <td> elements is
no longer 0 in quirks mode.  See bug 101084.

Martijn (or reporter?), what does IE do on the page in question?

Note that given the CSS and HTML on the page, and assuming we do want the bottom
margin there, the layout is exactly correct.

crot0@infoseek.jp, please do NOT mark layout bugs without minimal testcases as
confirmed like you did with this one.
Created attachment 156484 [details]
Screenshot of the page in IE6
Created attachment 156489 [details]
Testcase, not minimal 

I've trimmed the url testcase a bit down.

I've discovered something very strange with IE6. In the testcase they use
"<TD><H2> 9</TD>" like that. This doesn't cause a bottom margin in IE6. But
when I	'fix' the html to "<TD><H2> 9</H2></TD>" the bottom margin gets applied
in IE6.

*** This bug has been marked as a duplicate of 47793 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.