Closed Bug 256089 Opened 19 years ago Closed 19 years ago

Unable to create bookmark by drag-and-drop link to bookmark toolbar or menu

Categories

(Firefox :: Bookmarks & History, defect)

1.0 Branch
x86
Windows XP
defect
Not set
blocker

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: 32768, Assigned: bugs)

References

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040818 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040818 Firefox/0.9.1+

It used to be possible to drag and drop a link or the address bar icon to the
bookmark toolbar to create a bookmark.  This doesn't work anymore.

Looks like a regression.  Using Aviary nightly 20040818.

Reproducible: Always
Steps to Reproduce:
Drag the Mozilla icon from the address bar to an empty spot on the bookmarks
toolbar.
-or-
Drag a link on this page to an empty spot on the bookmarks toolbar.
Actual Results:  
Drag and drop icon appears while dragging, but no bookmark is created when mouse
button is released.

Expected Results:  
Create new bookmark when mouse button is released.
Same problem occurs in bookmarks menu; moving to "Bookmarks" component.
Component: Toolbars → Bookmarks
Summary: Unable to create bookmark by drag-and-drop link to bookmark toolbar → Unable to create bookmark by drag-and-drop link to bookmark toolbar or menu
Version: unspecified → 1.0 Branch

*** This bug has been marked as a duplicate of 256072 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Bug 256072's patch fixed this for a dragged proxy icon but not for dragged links.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
vladimir checked in a large change to bookmarks backend. cc'ing him
Severity: normal → blocker
Keywords: regression
*** Bug 256327 has been marked as a duplicate of this bug. ***
This also affects dragging to the desktop.  I know other bugs were
filed/fixed/whatever, but currently dragging a link to the desktop creates a
.url, dragging from the tab bar to the desktop does the same, dragging from the
location bar fails completely.
ignore my comment, Jesse just filed that as bug 256357
Flags: blocking-aviary1.0PR?
*** Bug 256787 has been marked as a duplicate of this bug. ***
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040826
Firefox/0.9.1+

WFM
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040826
Firefox/0.9.1+
WFM

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040825 Firefox/0.9.1+
WFM but its annoying that the menu disappears. The pointer is still over the
menu after you drop the link so why does the menu disappear, with it disapearing
you really don't know if the bookmark was created or not unless you click the
Bookmark s menu
Not sure I follow the menu bit, but feel free to file another bug. Closing this
one as WFM.
Status: NEW → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → WORKSFORME
NOT WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040825
Firefox/0.9.1+

I get the cursor, and can drag. Hovering over the menu/toolbar changes the mouse
cursor. So far so good. But releasing the mouse button doesn't actually create
the bookmark, and I get a beep instead.
(In reply to comment #14)
> NOT WFM
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040825
> Firefox/0.9.1+

The WFM comments are from today's build (20040826)

verified.
Status: RESOLVED → VERIFIED
Doesn't work for me... not fixed or has re-emerged.  When I drag the link from
the address bar into a bookmark folder found on the Bookmarks Toolbar Folder, I
hear a "beep"-type sound, and no bookmark is created.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040827
Firefox/0.9.1+
The build from the 26th did actually fix it for me, with a clean install
(installing over the top didn't work). Thats the program folder, I'm still using
the same profile.
This still does not work with the 083004 build.  I've reverted back to the
081604 build as the bug is not present with it or any prior to it.  I have (as
always) installed a new Firefox build (via the .zip file) without any
overwriting of files.  Simply put, dragging the link from the address bar to
either the Bookmarks Toolbar Folder bar or into Bookmark folders present on the
BTF bar results in the dragged bookmark not being saved into the desired
location (or anywhere for that matter).
This still does not work with the 083004 build.  I've reverted back to the
081604 build as the bug is not present with it or any prior to it.  I have (as
always) installed a new Firefox build (via the .zip file) without any
overwriting of files.  Simply put, dragging the link from the address bar to
either the Bookmarks Toolbar Folder bar or into Bookmark folders present on the
BTF bar results in the dragged bookmark not being saved into the desired
location (or anywhere for that matter).
Is this still a problem? If so, why is it resolved? If not, why is it still
nominated? Please reopen and renominate if this is a problem in the latest
branch nightly build. 
Flags: blocking-aviary1.0PR?
I'm not able to reproduce this with an 09/09 build.
this works for me as well. tested on Win XP Firefox branch build 2004-09-09-08-0.9
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040710

I experienced the same problem here -- I fixed it by creating a Folder inside my
Bookmarks folder called "Personal Toolbar Folder".  If this folder doesn't
exist, you won't be able to add bookmarks via DnD to the personal toolbar.

I experienced this problem only after all of my personal
settings/bookmarks/everything were lost for some reason.  Now I'm backing
critical Mozilla files up regularly.

To fix:

Bookmarks --> Manage Bookmarks --> New Folder --> Name = "Personal Toolbar
Folder" (no quotes)

At any rate, possibly a routine should exist such that if the "Personal Toolbar
Folder" does not exist, it is recreated if a user attempts to DnD a bookmark
onto the Personal Toolbar.  This is marked WFM probably by those people who have
this folder.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b2) Gecko/20050227 
Firefox/1.0+

The browser crashes, if I drag-and-drop the site icon onto the bookmarks 
toolbar. 
QA Contact: bugzilla → bookmarks
You need to log in before you can comment on or make changes to this bug.